summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIOhannes m zmölnig (Debian/GNU) <umlaeute@debian.org>2022-11-22 10:44:05 +0100
committerIOhannes m zmölnig (Debian/GNU) <umlaeute@debian.org>2022-11-22 10:44:05 +0100
commit7d9c788605e2428797f5d2d882ae50f49abd4919 (patch)
tree12d5383dfcff944738e6bb2dde337e2df25495f6
parent3617cf56d4e3d053fcd71ae30d1f22dd89d46d8b (diff)
Modernize 'licensecheck' target
-rwxr-xr-xdebian/rules8
1 files changed, 7 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index e8c7290..40cc312 100755
--- a/debian/rules
+++ b/debian/rules
@@ -30,8 +30,14 @@ override_dh_auto_install:
# remove license file so we can replace it with link to the Debian license file
rm -f -- $(CURDIR)/debian/*/$(pkglibdir)/*/LICENSE.txt
+DEB_COPYRIGHT_CHECK_IGNORE_REGEX = \
+ $(empty)
+# licensecheck v1
+.PHONY: licensecheck
licensecheck:
- licensecheck --deb-machine -r . \
+ licensecheck \
+ -i "^($(DEB_COPYRIGHT_CHECK_IGNORE_REGEX))$$" \
+ --check '.*' --recursive --deb-machine --lines 0 * \
> debian/copyright_newhints
cmp debian/copyright_hints debian/copyright_newhints \
&& rm debian/copyright_newhints