summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans-Christoph Steiner <hans@eds.org>2013-01-17 22:40:57 -0500
committerHans-Christoph Steiner <hans@eds.org>2013-01-17 22:41:34 -0500
commitbdb2e9de81ddbec4d86c535b7f486d541b33859c (patch)
treedfaf8c6bde2b48be702b6b7064dcb7230193b76f
parent70eb38ab15ec5e4365630960c39781f417574b79 (diff)
add patch to force .pd_linux as the binary file extension
-rw-r--r--debian/patches/force-pd_linux-as-extension39
-rw-r--r--debian/patches/series1
2 files changed, 40 insertions, 0 deletions
diff --git a/debian/patches/force-pd_linux-as-extension b/debian/patches/force-pd_linux-as-extension
new file mode 100644
index 0000000..d6998cc
--- /dev/null
+++ b/debian/patches/force-pd_linux-as-extension
@@ -0,0 +1,39 @@
+Description: force .pd_linux as binary file extension
+Author: Hans-Christoph Steiner <hans@eds.org>
+
+---
+
+Last-Update: <2013-01-17>
+
+--- pd-maxlib-1.5.5.orig/Makefile
++++ pd-maxlib-1.5.5/Makefile
+@@ -160,29 +160,6 @@ endif
+ ifeq ($(UNAME),Linux)
+ CPU := $(shell uname -m)
+ EXTENSION = pd_linux
+- ifeq ($(findstring arm,$(CPU)),arm)
+- EXTENSION = l_arm
+- endif
+- ifeq ($(CPU),i386)
+- EXTENSION = l_i386
+- endif
+- ifeq ($(CPU),i486)
+- EXTENSION = l_i386
+- endif
+- ifeq ($(CPU),i586)
+- EXTENSION = l_i386
+- endif
+- ifeq ($(CPU),i686)
+- EXTENSION = l_i386
+- endif
+- ifeq ($(CPU),amd64)
+- # amd64 and ia64 aren't the same thing, but that's how its done in pd...
+- EXTENSION = l_ia64
+- endif
+- ifeq ($(CPU),x86_64)
+- # x86_64 and ia64 aren't the same thing, but that's how its done in pd...
+- EXTENSION = l_ia64
+- endif
+ SOURCES += $(SOURCES_linux)
+ SHARED_EXTENSION = so
+ OS = linux
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..451e6b2
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+force-pd_linux-as-extension