summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 7 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index e8c7290..40cc312 100755
--- a/debian/rules
+++ b/debian/rules
@@ -30,8 +30,14 @@ override_dh_auto_install:
# remove license file so we can replace it with link to the Debian license file
rm -f -- $(CURDIR)/debian/*/$(pkglibdir)/*/LICENSE.txt
+DEB_COPYRIGHT_CHECK_IGNORE_REGEX = \
+ $(empty)
+# licensecheck v1
+.PHONY: licensecheck
licensecheck:
- licensecheck --deb-machine -r . \
+ licensecheck \
+ -i "^($(DEB_COPYRIGHT_CHECK_IGNORE_REGEX))$$" \
+ --check '.*' --recursive --deb-machine --lines 0 * \
> debian/copyright_newhints
cmp debian/copyright_hints debian/copyright_newhints \
&& rm debian/copyright_newhints