summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Schauer <josch@debian.org>2016-11-15 08:35:20 +0100
committerJohannes Schauer <josch@debian.org>2016-11-15 08:35:20 +0100
commitdbd96439c34a412c9a1c23979349219df0f58f13 (patch)
treeefe6236a17f03396a52f2acd628181655970de3f
parentda5832f7579233cc1fc1f4828265a9b1420e6e58 (diff)
drop patch allow-old-libfontforge after upload of libfontforge-dev 1:20161005~dfsg-4 to unstable and bump build dependency accordingly
-rw-r--r--CMakeLists.txt64
-rw-r--r--debian/changelog2
-rw-r--r--debian/control2
-rw-r--r--debian/patches/allow-old-libfontforge88
-rw-r--r--debian/patches/series1
-rw-r--r--src/util/ffw.c2
6 files changed, 8 insertions, 151 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b7282f5..52f89c3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -54,66 +54,10 @@ if(ENABLE_SVG)
endif()
# fontforge starts using pkg-config 'correctly' since 2.0.0
-pkg_check_modules(FONTFORGE libfontforge>=2.0.0)
-if(FONTFORGE_FOUND)
- include_directories(${FONTFORGE_INCLUDE_DIRS})
- link_directories(${FONTFORGE_LIBRARY_DIRS})
- set(PDF2HTMLEX_LIBS ${PDF2HTMLEX_LIBS} ${FONTFORGE_LIBRARIES})
-else()
- message("Trying to locate old versions of fontforge...")
- find_path(FF_INCLUDE_PATH fontforge/fontforge.h)
- if(FF_INCLUDE_PATH)
- message("Found fontforge.h: ${FF_INCLUDE_PATH}/fontforge/fontforge.h")
- set(FONTFORGE_INCLUDE_DIRS ${FF_INCLUDE_PATH}/fontforge)
- include_directories(${FONTFORGE_INCLUDE_DIRS})
- # MacOSX gettext is in /opt/local/include - strange
- if(${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
- find_path(GETTEXT_INCLUDE_PATH libintl.h HINTS "/usr/local/opt/gettext/include") # homebrew
- if(GETTEXT_INCLUDE_PATH)
- include_directories(${GETTEXT_INCLUDE_PATH})
- else()
- message("Cannot found libintl.h, if you see errors about libintl.h, add the path to gettext header files into your include paths")
- endif()
- endif()
- else()
- message(FATAL_ERROR "Error: cannot locate fontforge.h")
- endif()
- find_path(FF_CONFIG_INCLUDE_PATH config.h PATHS ${FONTFORGE_INCLUDE_DIRS} NO_DEFAULT_PATH)
- if(FF_CONFIG_INCLUDE_PATH)
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -include ${FF_CONFIG_INCLUDE_PATH}/config.h")
- message("Found config.h: ${FF_CONFIG_INCLUDE_PATH}/config.h")
- else()
- message("Cannot locate config.h for fontforge")
- endif()
-
- macro(wl_find_library LIB_NAME RESULT)
- unset(${RESULT})
- unset(${RESULT} CACHE)
- foreach(FULL_LIB_NAME
- ${CMAKE_IMPORT_LIBRARY_PREFIX}${LIB_NAME}${CMAKE_IMPORT_LIBRARY_SUFFIX}
- ${CMAKE_SHARED_LIBRARY_PREFIX}${LIB_NAME}${CMAKE_SHARED_LIBRARY_SUFFIX}
- ${CMAKE_STATIC_LIBRARY_PREFIX}${LIB_NAME}${CMAKE_STATIC_LIBRARY_SUFFIX}
- )
- find_library(FULL_LIB ${FULL_LIB_NAME})
- if(FULL_LIB)
- message("Found ${LIB_NAME}: ${FULL_LIB}")
- set(${RESULT} ${FULL_LIB})
- break()
- endif()
- endforeach()
- unset(FULL_LIB_NAME)
- unset(FULL_LIB_NAME CACHE)
- unset(FULL_LIB)
- unset(FULL_LIB CACHE)
- endmacro()
-
- wl_find_library(fontforge FONTFORGE_LIBRARIES)
- if(NOT DEFINED FONTFORGE_LIBRARIES)
- set(FONTFORGE_LIBRARIES fontforge)
- message("Error: cannot locate fontforge")
- endif()
- set(PDF2HTMLEX_LIBS ${PDF2HTMLEX_LIBS} ${FONTFORGE_LIBRARIES})
-endif()
+pkg_check_modules(FONTFORGE REQUIRED libfontforge>=2.0.0)
+include_directories(${FONTFORGE_INCLUDE_DIRS})
+link_directories(${FONTFORGE_LIBRARY_DIRS})
+set(PDF2HTMLEX_LIBS ${PDF2HTMLEX_LIBS} ${FONTFORGE_LIBRARIES})
# debug build flags (overwrite default cmake debug flags)
set(CMAKE_C_FLAGS_DEBUG "-ggdb -pg")
diff --git a/debian/changelog b/debian/changelog
index 0631cc4..13ee835 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,8 @@
pdf2htmlex (0.14.6+ds-3) UNRELEASED; urgency=medium
* bump debhelper compat level to 10 (closes: #823262)
+ * drop patch allow-old-libfontforge after upload of libfontforge-dev
+ 1:20161005~dfsg-4 to unstable and bump build dependency accordingly
-- Johannes Schauer <josch@debian.org> Tue, 15 Nov 2016 08:24:04 +0100
diff --git a/debian/control b/debian/control
index 69c22fc..c16e0ab 100644
--- a/debian/control
+++ b/debian/control
@@ -10,7 +10,7 @@ Build-Depends:
libpoppler-private-dev,
libpng-dev,
libjpeg-dev,
- libfontforge-dev,
+ libfontforge-dev (>= 1:20161005~dfsg-4),
libspiro-dev,
python,
yui-compressor,
diff --git a/debian/patches/allow-old-libfontforge b/debian/patches/allow-old-libfontforge
deleted file mode 100644
index 5b50707..0000000
--- a/debian/patches/allow-old-libfontforge
+++ /dev/null
@@ -1,88 +0,0 @@
-From: 王璐 Lu Wang <coolwanglu@gmail.com>
-Subject: reverting commit: remove support for old versions of fontforge
-Origin: upstream, https://github.com/coolwanglu/pdf2htmlEX/commit/15ac5271a72ad2fff36f4b91697e0335a00bd9b1
-
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -54,10 +54,66 @@ if(ENABLE_SVG)
- endif()
-
- # fontforge starts using pkg-config 'correctly' since 2.0.0
--pkg_check_modules(FONTFORGE REQUIRED libfontforge>=2.0.0)
--include_directories(${FONTFORGE_INCLUDE_DIRS})
--link_directories(${FONTFORGE_LIBRARY_DIRS})
--set(PDF2HTMLEX_LIBS ${PDF2HTMLEX_LIBS} ${FONTFORGE_LIBRARIES})
-+pkg_check_modules(FONTFORGE libfontforge>=2.0.0)
-+if(FONTFORGE_FOUND)
-+ include_directories(${FONTFORGE_INCLUDE_DIRS})
-+ link_directories(${FONTFORGE_LIBRARY_DIRS})
-+ set(PDF2HTMLEX_LIBS ${PDF2HTMLEX_LIBS} ${FONTFORGE_LIBRARIES})
-+else()
-+ message("Trying to locate old versions of fontforge...")
-+ find_path(FF_INCLUDE_PATH fontforge/fontforge.h)
-+ if(FF_INCLUDE_PATH)
-+ message("Found fontforge.h: ${FF_INCLUDE_PATH}/fontforge/fontforge.h")
-+ set(FONTFORGE_INCLUDE_DIRS ${FF_INCLUDE_PATH}/fontforge)
-+ include_directories(${FONTFORGE_INCLUDE_DIRS})
-+ # MacOSX gettext is in /opt/local/include - strange
-+ if(${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
-+ find_path(GETTEXT_INCLUDE_PATH libintl.h HINTS "/usr/local/opt/gettext/include") # homebrew
-+ if(GETTEXT_INCLUDE_PATH)
-+ include_directories(${GETTEXT_INCLUDE_PATH})
-+ else()
-+ message("Cannot found libintl.h, if you see errors about libintl.h, add the path to gettext header files into your include paths")
-+ endif()
-+ endif()
-+ else()
-+ message(FATAL_ERROR "Error: cannot locate fontforge.h")
-+ endif()
-+ find_path(FF_CONFIG_INCLUDE_PATH config.h PATHS ${FONTFORGE_INCLUDE_DIRS} NO_DEFAULT_PATH)
-+ if(FF_CONFIG_INCLUDE_PATH)
-+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -include ${FF_CONFIG_INCLUDE_PATH}/config.h")
-+ message("Found config.h: ${FF_CONFIG_INCLUDE_PATH}/config.h")
-+ else()
-+ message("Cannot locate config.h for fontforge")
-+ endif()
-+
-+ macro(wl_find_library LIB_NAME RESULT)
-+ unset(${RESULT})
-+ unset(${RESULT} CACHE)
-+ foreach(FULL_LIB_NAME
-+ ${CMAKE_IMPORT_LIBRARY_PREFIX}${LIB_NAME}${CMAKE_IMPORT_LIBRARY_SUFFIX}
-+ ${CMAKE_SHARED_LIBRARY_PREFIX}${LIB_NAME}${CMAKE_SHARED_LIBRARY_SUFFIX}
-+ ${CMAKE_STATIC_LIBRARY_PREFIX}${LIB_NAME}${CMAKE_STATIC_LIBRARY_SUFFIX}
-+ )
-+ find_library(FULL_LIB ${FULL_LIB_NAME})
-+ if(FULL_LIB)
-+ message("Found ${LIB_NAME}: ${FULL_LIB}")
-+ set(${RESULT} ${FULL_LIB})
-+ break()
-+ endif()
-+ endforeach()
-+ unset(FULL_LIB_NAME)
-+ unset(FULL_LIB_NAME CACHE)
-+ unset(FULL_LIB)
-+ unset(FULL_LIB CACHE)
-+ endmacro()
-+
-+ wl_find_library(fontforge FONTFORGE_LIBRARIES)
-+ if(NOT DEFINED FONTFORGE_LIBRARIES)
-+ set(FONTFORGE_LIBRARIES fontforge)
-+ message("Error: cannot locate fontforge")
-+ endif()
-+ set(PDF2HTMLEX_LIBS ${PDF2HTMLEX_LIBS} ${FONTFORGE_LIBRARIES})
-+endif()
-
- # debug build flags (overwrite default cmake debug flags)
- set(CMAKE_C_FLAGS_DEBUG "-ggdb -pg")
---- a/src/util/ffw.c
-+++ b/src/util/ffw.c
-@@ -99,7 +99,7 @@ void ffw_finalize(void)
-
- long ffw_get_version(void)
- {
-- return FONTFORGE_VERSIONDATE_RAW;
-+ return library_version_configuration.library_source_versiondate;
- }
-
- void ffw_new_font()
diff --git a/debian/patches/series b/debian/patches/series
index fb31e62..99983cb 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -4,7 +4,6 @@ use-system-pdfjs
use-rsvg
use-system-compatibilityjs-non-min
do-not-ship-unused-js
-allow-old-libfontforge
fix-spelling
control-test-executable-name
disable-local-browser-test
diff --git a/src/util/ffw.c b/src/util/ffw.c
index 6573282..b88efce 100644
--- a/src/util/ffw.c
+++ b/src/util/ffw.c
@@ -99,7 +99,7 @@ void ffw_finalize(void)
long ffw_get_version(void)
{
- return library_version_configuration.library_source_versiondate;
+ return FONTFORGE_VERSIONDATE_RAW;
}
void ffw_new_font()