summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog8
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules8
3 files changed, 12 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index 469338f..44c89a5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+pdmenu (1.3.3) UNRELEASED; urgency=medium
+
+ * Added autotools-dev to the build to update config.{guess,sub},
+ and do it before the clean target. Closes: #756569
+ Thanks, Fernando Seiti Furusato.
+
+ -- Fernando Seiti Furusato <ferseiti@br.ibm.com> Wed, 30 Jul 2014 22:51:44 +0000
+
pdmenu (1.3.2) unstable; urgency=low
* debian/rules: use dh
diff --git a/debian/control b/debian/control
index be1976e..5a1dbfd 100644
--- a/debian/control
+++ b/debian/control
@@ -1,7 +1,7 @@
Source: pdmenu
Section: shells
Priority: optional
-Build-Depends: debhelper (>= 8), libslang2-dev (>= 1.4.4-3), libgpm-dev [!hurd-any !kfreebsd-any], gettext, dpkg-dev (>= 1.9.0)
+Build-Depends: debhelper (>= 8), autotools-dev, libslang2-dev (>= 1.4.4-3), libgpm-dev [!hurd-any !kfreebsd-any], gettext, dpkg-dev (>= 1.9.0)
Maintainer: Joey Hess <joeyh@debian.org>
Standards-Version: 3.9.2
Vcs-Git: git://git.kitenet.net/pdmenu
diff --git a/debian/rules b/debian/rules
index 85bdf71..98961eb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,7 +4,7 @@ CFLAGS=-O2 -Wall -g
INSTALL_PROGRAM=install
%:
- dh $@
+ dh $@ --with autotools_dev
override_dh_auto_configure:
./configure $(GPMCONFIG) --prefix=/usr --sysconfdir=/etc \
@@ -14,11 +14,9 @@ override_dh_auto_test:
# make test is interactive; skip it
override_dh_auto_clean:
+ dh_autotools-dev_updateconfig
if [ -e Makefile ]; then $(MAKE) distclean; fi
- -test -r /usr/share/misc/config.sub && \
- cp -f /usr/share/misc/config.sub autoconf/config.sub
- -test -r /usr/share/misc/config.guess && \
- cp -f /usr/share/misc/config.guess autoconf/config.guess
+ dh_autotools-dev_restoreconfig
override_dh_auto_install:
$(MAKE) INSTALL_PREFIX=debian/pdmenu \