summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2021-02-01 10:16:29 -0700
committerSean Whitton <spwhitton@spwhitton.name>2021-02-01 10:16:29 -0700
commitf8f17f7d245fe93decacfbc9fba44cc55290f75d (patch)
tree2f537a7c203f17e65ff2b7e94bcab7f4cf580a77
parentb5841b119e33400615fa7196ceac0da843de1dd4 (diff)
cherry-pick upstream commit 7ca375cb
-rw-r--r--debian/changelog8
-rw-r--r--debian/patches/Fix-test_tokenfilter_is_abstract.patch17
-rw-r--r--debian/patches/series1
3 files changed, 26 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 8a893a6..dcb4c79 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+pikepdf (1.17.3+dfsg-4) UNRELEASED; urgency=medium
+
+ * Cherry-pick upstream commit 7ca375cb to fix another broken text
+ (Closes: #981465).
+ Thanks to Jay Berkenbilt for investigation.
+
+ -- Sean Whitton <spwhitton@spwhitton.name> Mon, 01 Feb 2021 10:15:51 -0700
+
pikepdf (1.17.3+dfsg-3) unstable; urgency=medium
* Fix bug number closed by previous upload.
diff --git a/debian/patches/Fix-test_tokenfilter_is_abstract.patch b/debian/patches/Fix-test_tokenfilter_is_abstract.patch
new file mode 100644
index 0000000..1a36c84
--- /dev/null
+++ b/debian/patches/Fix-test_tokenfilter_is_abstract.patch
@@ -0,0 +1,17 @@
+From: "James R. Barlow" <james@purplerock.ca>
+Date: Wed, 6 Jan 2021 03:39:50 -0800
+Subject: Fix test_tokenfilter_is_abstract
+
+---
+ tests/test_filters.py | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/tests/test_filters.py b/tests/test_filters.py
+index 33124bf..5604961 100644
+--- a/tests/test_filters.py
++++ b/tests/test_filters.py
+@@ -88,4 +88,3 @@ def test_tokenfilter_is_abstract(pal):
+ page = pikepdf.Page(pal.pages[0])
+ with pytest.raises((RuntimeError, pikepdf.PdfError)):
+ page.get_filtered_contents(pikepdf.TokenFilter())
+- assert 'Tried to call pure virtual' in pal.get_warnings()[0]
diff --git a/debian/patches/series b/debian/patches/series
index 0205874..56b42eb 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -5,3 +5,4 @@ drop-save-pike.patch
Fix-compatibility-with-pybind11.patch
Fix-externalize_inline_images-for-qpdf-10.1.0.patch
libqpdf-10.1.0-raises-different-exception.patch
+Fix-test_tokenfilter_is_abstract.patch