summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--README.md2
-rw-r--r--pyproject.toml3
-rw-r--r--setup.cfg1
3 files changed, 3 insertions, 3 deletions
diff --git a/README.md b/README.md
index 1023cb3..c33ac93 100644
--- a/README.md
+++ b/README.md
@@ -39,7 +39,7 @@ This library is similar to PyPDF2 and pdfrw - it provides low level access to PD
| Based on an existing, mature PDF library | QPDF | ✘ | ✘ |
| Implementation | C++ and Python | Python | Python |
| PDF versions supported | 1.1 to 1.7 | 1.3? | 1.7 |
-| Python versions supported | 3.6-3.9 | 2.6-3.6 | 2.6-3.6 |
+| Python versions supported | 3.6-3.10 | 2.6-3.6 | 2.6-3.6 |
| Save and load password protected (encrypted) PDFs | ✔ (except public key) | ✘ (Only obsolete RC4) | ✘ (not at all) |
| Save and load PDF compressed object streams (PDF 1.5) | ✔ | ✘ | ✘ |
| Creates linearized ("fast web view") PDFs | ✔ | ✘ | ✘ |
diff --git a/pyproject.toml b/pyproject.toml
index e8a8e69..467ad7f 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -37,7 +37,6 @@ exclude = '''
[tool.cibuildwheel]
test-command = "pytest -nauto {project}/tests"
test-extras = "test"
-skip = "cp310-*"
test-skip = "*_arm64 *_universal2:arm64"
[tool.cibuildwheel.environment]
@@ -65,7 +64,7 @@ before-all = "brew install qpdf"
# pp3*-win_amd64 does not execute because cibuildwheel does not implement it
# or PyPy3 doesn't work on Windows 64-bit, one or the other
# PyPy+Win32 seems like a very low priority combination
-skip = "pp3* cp310-*"
+skip = "pp3*"
[tool.mypy]
diff --git a/setup.cfg b/setup.cfg
index 548441b..108cc92 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -23,6 +23,7 @@ classifiers =
Programming Language :: Python :: 3.7
Programming Language :: Python :: 3.8
Programming Language :: Python :: 3.9
+ Programming Language :: Python :: 3.10
Programming Language :: Python :: Implementation :: CPython
Programming Language :: Python :: Implementation :: PyPy
Topic :: Multimedia :: Graphics