summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2019-10-18 14:12:32 +0200
committerDidier Raboud <odyx@debian.org>2019-10-18 14:12:32 +0200
commite8136c29c666c1b1fd6c3921a4c2193efc2cb24c (patch)
treed80ff33c777040b4dea5caca8cb69f0450d2d4c5
parent0c185033e2e00a9f75cb961449faa66a3225869a (diff)
parentccca72c23af2d90020fe7cbf3fb5a4b09a87e041 (diff)
Record planetblupi (1.14.2-1) in archive suite sid
-rw-r--r--CMakeLists.txt2
-rw-r--r--debian/changelog8
-rw-r--r--debian/control2
-rw-r--r--debian/patches/0001-Fix-bad-translation.patch21
-rw-r--r--debian/patches/0002-Do-not-play-the-win-sound-while-the-win-video-is-pla.patch84
-rw-r--r--debian/patches/series2
-rw-r--r--debian/upstream/metadata1
-rw-r--r--src/event.cxx2
-rw-r--r--src/sound.cxx17
-rw-r--r--src/sound.h2
10 files changed, 12 insertions, 129 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 00c3750..5723efd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,7 +15,7 @@ link_directories (${CMAKE_INSTALL_PREFIX}/lib)
project (planetblupi)
set (PB_VERSION_MAJOR 1)
set (PB_VERSION_MINOR 14)
-set (PB_VERSION_PATCH 1)
+set (PB_VERSION_PATCH 2)
set (PB_VERSION_EXTRA "")
set (PB_PRODUCT_NAME "Planet Blupi")
set (PB_PACKAGE_NAME "planetblupi")
diff --git a/debian/changelog b/debian/changelog
index 75be072..8d5b7c3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+planetblupi (1.14.2-1) unstable; urgency=medium
+
+ * New 1.14.2 upstream release
+ * Bump S-V to 4.4.1 without changes needed
+ * Set upstream metadata fields: Repository.
+
+ -- Didier Raboud <odyx@debian.org> Fri, 18 Oct 2019 14:12:32 +0200
+
planetblupi (1.14.1-2) unstable; urgency=medium
* Move to unstable
diff --git a/debian/control b/debian/control
index e5a242a..4dc111a 100644
--- a/debian/control
+++ b/debian/control
@@ -17,7 +17,7 @@ Build-Depends-Indep:
timidity,
vorbis-tools,
timgm6mb-soundfont,
-Standards-Version: 4.4.0
+Standards-Version: 4.4.1
Rules-Requires-Root: no
Homepage: http://blupi.org
Vcs-Git: https://salsa.debian.org/games-team/planetblupi.git
diff --git a/debian/patches/0001-Fix-bad-translation.patch b/debian/patches/0001-Fix-bad-translation.patch
deleted file mode 100644
index 1b4c491..0000000
--- a/debian/patches/0001-Fix-bad-translation.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From: Mathieu Schroeter <mathieu@schroetersa.ch>
-Date: Mon, 22 Apr 2019 14:06:40 +0200
-Subject: Fix bad translation
-
----
- resources/data/en/stories.blp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/resources/data/en/stories.blp b/resources/data/en/stories.blp
-index 4f96ebc..728ec41 100644
---- a/resources/data/en/stories.blp
-+++ b/resources/data/en/stories.blp
-@@ -443,7 +443,7 @@ clicking on each Blupi.
- 1|Goal:
- 1|
- 1|Reach the island in the
--1|north-east and blow the
-+1|north-west and blow the
- 1|palisade up.
-
- 2|All you have to do now is
diff --git a/debian/patches/0002-Do-not-play-the-win-sound-while-the-win-video-is-pla.patch b/debian/patches/0002-Do-not-play-the-win-sound-while-the-win-video-is-pla.patch
deleted file mode 100644
index 71b8dd4..0000000
--- a/debian/patches/0002-Do-not-play-the-win-sound-while-the-win-video-is-pla.patch
+++ /dev/null
@@ -1,84 +0,0 @@
-From: Mathieu Schroeter <mathieu@schroetersa.ch>
-Date: Fri, 6 Sep 2019 23:34:55 +0200
-Subject: Do not play the win sound while the win video is playing
-
-The win sound must be played only with the win screens.
----
- src/blupi.cxx | 30 ++++++++++++++++++++++++++----
- src/decblupi.cxx | 14 +-------------
- 2 files changed, 27 insertions(+), 17 deletions(-)
-
-diff --git a/src/blupi.cxx b/src/blupi.cxx
-index 5dd9532..e9fe1ec 100644
---- a/src/blupi.cxx
-+++ b/src/blupi.cxx
-@@ -77,10 +77,11 @@ bool g_restoreMidi = false; // restore music playback based on midi files
- bool g_renderQuality = true; // use the best render quality with scaling
- int g_settingsOverload = 0;
-
--bool g_bTermInit = false; // initialisation en cours
--Uint32 g_lastPhase = 999;
--RestartMode g_restart = RestartMode::NO;
--static bool g_pause;
-+bool g_bTermInit = false; // initialisation en cours
-+Uint32 g_lastPhase = 999;
-+RestartMode g_restart = RestartMode::NO;
-+static bool g_pause;
-+static Uint32 g_prevPhase = 0;
-
- #ifdef USE_CURL
- struct url_data {
-@@ -292,6 +293,27 @@ Update (void)
- g_pEvent->ChangePhase (EV_PHASE_WINMOVIE); // win
- }
-
-+ if (g_prevPhase != phase)
-+ {
-+ Point pos;
-+
-+ pos.x = LXIMAGE () / 2;
-+ pos.y = LYIMAGE () / 2;
-+
-+ if (phase == EV_PHASE_LOST)
-+ {
-+ if (!g_pSound->PlayImage (SOUND_LOST, pos))
-+ g_pSound->PlayImage (SOUND_GOAL, pos);
-+ }
-+ else if (phase == EV_PHASE_WIN || phase == EV_PHASE_LASTWIN)
-+ {
-+ if (!g_pSound->PlayImage (SOUND_WIN, pos))
-+ g_pSound->PlayImage (SOUND_GOAL, pos);
-+ }
-+ }
-+
-+ g_prevPhase = phase;
-+
- return display;
- }
-
-diff --git a/src/decblupi.cxx b/src/decblupi.cxx
-index 1475e4a..94fb19f 100644
---- a/src/decblupi.cxx
-+++ b/src/decblupi.cxx
-@@ -4713,20 +4713,8 @@ CDecor::IsTerminated ()
- delay:
- m_winCount = count;
- if (m_winCount == 0)
-- {
-- if (out == 1) // perdu ?
-- {
-- if (!m_pSound->PlayImage (SOUND_LOST, pos))
-- m_pSound->PlayImage (SOUND_GOAL, pos);
-- }
-- else
-- {
-- if (!m_pSound->PlayImage (SOUND_WIN, pos))
-- m_pSound->PlayImage (SOUND_GOAL, pos);
-- }
--
- return out; // perdu/gagné
-- }
-+
- m_winCount--;
- return 0; // continue
- }
diff --git a/debian/patches/series b/debian/patches/series
deleted file mode 100644
index 24461c6..0000000
--- a/debian/patches/series
+++ /dev/null
@@ -1,2 +0,0 @@
-0001-Fix-bad-translation.patch
-0002-Do-not-play-the-win-sound-while-the-win-video-is-pla.patch
diff --git a/debian/upstream/metadata b/debian/upstream/metadata
new file mode 100644
index 0000000..d73e564
--- /dev/null
+++ b/debian/upstream/metadata
@@ -0,0 +1 @@
+Repository: https://github.com/blupi-games/planetblupi
diff --git a/src/event.cxx b/src/event.cxx
index 05832f3..1fc70d4 100644
--- a/src/event.cxx
+++ b/src/event.cxx
@@ -5814,7 +5814,6 @@ CEvent::TreatEventBase (const SDL_Event & event)
if (m_bRunMovie)
{
StopMovie ();
- m_pSound->SetSuspendSkip (1);
return true;
}
@@ -5949,7 +5948,6 @@ CEvent::TreatEventBase (const SDL_Event & event)
if (m_bRunMovie)
{
StopMovie ();
- m_pSound->SetSuspendSkip (1);
return true;
}
m_pDecor->FlipOutline ();
diff --git a/src/sound.cxx b/src/sound.cxx
index 0a899bc..579e724 100644
--- a/src/sound.cxx
+++ b/src/sound.cxx
@@ -83,7 +83,6 @@ CSound::CSound ()
m_audioVolume = 20;
m_midiVolume = 15;
m_lastMidiVolume = 0;
- m_nbSuspendSkip = 0;
m_pMusic = nullptr;
m_bStopped = false;
@@ -123,7 +122,7 @@ bool
CSound::Create ()
{
if (
- Mix_OpenAudio (44100, MIX_DEFAULT_FORMAT, MIX_DEFAULT_CHANNELS, 4096) == -1)
+ Mix_OpenAudio (44100, MIX_DEFAULT_FORMAT, MIX_DEFAULT_CHANNELS, 1024) == -1)
return false;
Mix_AllocateChannels (MAXSOUND);
@@ -407,12 +406,6 @@ CSound::RestartMusic ()
void
CSound::SuspendMusic ()
{
- if (m_nbSuspendSkip != 0)
- {
- m_nbSuspendSkip--;
- return;
- }
-
m_bStopped = true;
Mix_HaltMusic ();
}
@@ -451,11 +444,3 @@ CSound::AdaptVolumeMusic ()
m_lastMidiVolume = m_midiVolume;
}
}
-
-// Indique le nombre de suspend � sauter.
-
-void
-CSound::SetSuspendSkip (Sint32 nb)
-{
- m_nbSuspendSkip = nb;
-}
diff --git a/src/sound.h b/src/sound.h
index 93e611e..b2f6edb 100644
--- a/src/sound.h
+++ b/src/sound.h
@@ -69,7 +69,6 @@ public:
bool IsPlayingMusic ();
bool IsStoppedOnDemand ();
void AdaptVolumeMusic ();
- void SetSuspendSkip (Sint32 nb);
void StopSound (bool immediat, Sint32 rank);
bool StopAllSounds (bool immediat, const std::set<Sint32> * except = nullptr);
@@ -84,5 +83,4 @@ protected:
Sint32 m_audioVolume;
Sint32 m_midiVolume;
Sint32 m_lastMidiVolume;
- Sint32 m_nbSuspendSkip;
};