summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CMakeLists.txt4
-rw-r--r--debian/changelog13
-rw-r--r--debian/control58
-rw-r--r--debian/patches/0001-Avoid-making-assumptions-about-location-of-SDL2-head.patch41
-rw-r--r--debian/patches/series1
-rw-r--r--debian/upstream/metadata5
6 files changed, 88 insertions, 34 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5723efd..f067233 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,7 +9,6 @@ include (${CMAKE_ROOT}/Modules/ExternalProject.cmake)
include ("${CMAKE_SOURCE_DIR}/cmake/Ronn2Man.cmake")
include_directories (${CMAKE_INSTALL_PREFIX}/include)
-include_directories (${CMAKE_INSTALL_PREFIX}/include/SDL2)
link_directories (${CMAKE_INSTALL_PREFIX}/lib)
project (planetblupi)
@@ -153,10 +152,13 @@ include_directories (${SDLKitchensink_INCLUDE_DIRS})
find_package (PkgConfig REQUIRED)
if (NOT BUILD_JS)
pkg_search_module (SDL2 REQUIRED sdl2)
+ include_directories (${SDL2_INCLUDE_DIRS})
set (planetblupi_DEPS ${planetblupi_DEPS} ${SDL2_STATIC_LIBRARIES})
pkg_search_module (SDL2_IMAGE REQUIRED SDL2_image)
+ include_directories (${SDL2_IMAGE_INCLUDE_DIRS})
set (planetblupi_DEPS ${planetblupi_DEPS} ${SDL2_IMAGE_STATIC_LIBRARIES})
pkg_search_module (SDL2_MIXER REQUIRED SDL2_mixer)
+ include_directories (${SDL2_MIXER_INCLUDE_DIRS})
set (planetblupi_DEPS ${planetblupi_DEPS} ${SDL2_MIXER_STATIC_LIBRARIES})
endif ()
diff --git a/debian/changelog b/debian/changelog
index 8d5b7c3..f3d8fff 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,16 @@
+planetblupi (1.14.2-2) unstable; urgency=medium
+
+ [ Simon McVittie ]
+ * d/p/Avoid-making-assumptions-about-location-of-SDL2-headers.patch:
+ Don't assume that SDL2 headers are in /usr/include/SDL2
+ (Closes: #952105)
+
+ [ Didier Raboud ]
+ * lintian-brush: Set some upstream metadata fields
+ * Bump Standards-Version to 4.5.0, cleanup versions
+
+ -- Didier Raboud <odyx@debian.org> Mon, 09 Mar 2020 20:13:59 +0100
+
planetblupi (1.14.2-1) unstable; urgency=medium
* New 1.14.2 upstream release
diff --git a/debian/control b/debian/control
index 4dc111a..995d345 100644
--- a/debian/control
+++ b/debian/control
@@ -1,33 +1,32 @@
Source: planetblupi
-Section: games
-Priority: optional
Maintainer: Debian Games Team <pkg-games-devel@lists.alioth.debian.org>
Uploaders: Didier Raboud <odyx@debian.org>
-Build-Depends:
- debhelper-compat (= 12),
- cmake,
- pkg-config,
- libsdl2-dev,
- libsdl2-image-dev,
- libsdl2-mixer-dev,
- libsdl-kitchensink-dev (>= 1),
- argagg-dev,
- ronn,
-Build-Depends-Indep:
- timidity,
- vorbis-tools,
- timgm6mb-soundfont,
-Standards-Version: 4.4.1
-Rules-Requires-Root: no
-Homepage: http://blupi.org
-Vcs-Git: https://salsa.debian.org/games-team/planetblupi.git
+Section: games
+Priority: optional
+Build-Depends: debhelper-compat (= 12),
+ cmake,
+ pkg-config,
+ libsdl2-dev,
+ libsdl2-image-dev,
+ libsdl2-mixer-dev,
+ libsdl-kitchensink-dev,
+ argagg-dev,
+ ronn
+Build-Depends-Indep: timidity,
+ vorbis-tools,
+ timgm6mb-soundfont
+Standards-Version: 4.5.0
Vcs-Browser: https://salsa.debian.org/games-team/planetblupi
+Vcs-Git: https://salsa.debian.org/games-team/planetblupi.git
+Homepage: http://blupi.org
+Rules-Requires-Root: no
Package: planetblupi
Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends},
- planetblupi-common (>= ${source:Version}),
- planetblupi-music-ogg (>= ${source:Version}) | planetblupi-music-midi (>= ${source:Version}),
+Depends: ${shlibs:Depends},
+ ${misc:Depends},
+ planetblupi-common (>= ${source:Version}),
+ planetblupi-music-ogg (>= ${source:Version}) | planetblupi-music-midi (>= ${source:Version})
Description: Planet Blupi - A delirious spell-binding game
Planet Blupi is a strategy and adventure game. It subtly blends action with
thought-provoking challenges. Behind the quiet and gentle facade, you'll enjoy
@@ -37,9 +36,8 @@ Package: planetblupi-common
Architecture: all
Multi-Arch: foreign
Depends: ${misc:Depends}
+Recommends: planetblupi (>= ${source:Version})
Enhances: planetblupi
-Recommends:
- planetblupi (>= ${source:Version})
Description: Planet Blupi - A delirious spell-binding game - data
Planet Blupi is a strategy and adventure game. It subtly blends action with
thought-provoking challenges. Behind the quiet and gentle facade, you'll enjoy
@@ -51,10 +49,8 @@ Package: planetblupi-music-ogg
Architecture: all
Multi-Arch: foreign
Depends: ${misc:Depends}
-Enhances: planetblupi
Recommends: planetblupi (>= ${source:Version})
-Replaces: planetblupi-common (<< 1.12.1-22-g13a7e27-1)
-Breaks: planetblupi-common (<< 1.12.1-22-g13a7e27-1)
+Enhances: planetblupi
Description: Planet Blupi - A delirious spell-binding game - Ogg music
Planet Blupi is a strategy and adventure game. It subtly blends action with
thought-provoking challenges. Behind the quiet and gentle facade, you'll enjoy
@@ -66,12 +62,10 @@ Package: planetblupi-music-midi
Architecture: all
Multi-Arch: foreign
Depends: ${misc:Depends},
- fluidr3mono-gm-soundfont | timgm6mb-soundfont | fluid-soundfont-gm,
+ fluidr3mono-gm-soundfont | timgm6mb-soundfont | fluid-soundfont-gm
+Recommends: planetblupi (>= ${source:Version})
# ^ these are libfluidsynth's suggests
Enhances: planetblupi
-Recommends: planetblupi (>= ${source:Version})
-Replaces: planetblupi-common (<< 1.12.1-22-g13a7e27-1)
-Breaks: planetblupi-common (<< 1.12.1-22-g13a7e27-1)
Description: Planet Blupi - A delirious spell-binding game - MIDI music
Planet Blupi is a strategy and adventure game. It subtly blends action with
thought-provoking challenges. Behind the quiet and gentle facade, you'll enjoy
diff --git a/debian/patches/0001-Avoid-making-assumptions-about-location-of-SDL2-head.patch b/debian/patches/0001-Avoid-making-assumptions-about-location-of-SDL2-head.patch
new file mode 100644
index 0000000..4737c6d
--- /dev/null
+++ b/debian/patches/0001-Avoid-making-assumptions-about-location-of-SDL2-head.patch
@@ -0,0 +1,41 @@
+From: Simon McVittie <smcv@debian.org>
+Date: Sun, 23 Feb 2020 18:12:58 +0000
+Subject: Avoid making assumptions about location of SDL2 headers
+
+It is not an API guarantee that the SDL2 headers will be found in
+${prefix}/include/SDL2, or that SDL2 is installed in the same prefix
+as planetblupi itself. Ask pkg-config instead.
+
+Signed-off-by: Simon McVittie <smcv@debian.org>
+Bug-Debian: https://bugs.debian.org/952105
+Forwarded: no
+---
+ CMakeLists.txt | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 5723efd..f067233 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -9,7 +9,6 @@ include (${CMAKE_ROOT}/Modules/ExternalProject.cmake)
+ include ("${CMAKE_SOURCE_DIR}/cmake/Ronn2Man.cmake")
+
+ include_directories (${CMAKE_INSTALL_PREFIX}/include)
+-include_directories (${CMAKE_INSTALL_PREFIX}/include/SDL2)
+ link_directories (${CMAKE_INSTALL_PREFIX}/lib)
+
+ project (planetblupi)
+@@ -153,10 +152,13 @@ include_directories (${SDLKitchensink_INCLUDE_DIRS})
+ find_package (PkgConfig REQUIRED)
+ if (NOT BUILD_JS)
+ pkg_search_module (SDL2 REQUIRED sdl2)
++ include_directories (${SDL2_INCLUDE_DIRS})
+ set (planetblupi_DEPS ${planetblupi_DEPS} ${SDL2_STATIC_LIBRARIES})
+ pkg_search_module (SDL2_IMAGE REQUIRED SDL2_image)
++ include_directories (${SDL2_IMAGE_INCLUDE_DIRS})
+ set (planetblupi_DEPS ${planetblupi_DEPS} ${SDL2_IMAGE_STATIC_LIBRARIES})
+ pkg_search_module (SDL2_MIXER REQUIRED SDL2_mixer)
++ include_directories (${SDL2_MIXER_INCLUDE_DIRS})
+ set (planetblupi_DEPS ${planetblupi_DEPS} ${SDL2_MIXER_STATIC_LIBRARIES})
+ endif ()
+
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..5a77707
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+0001-Avoid-making-assumptions-about-location-of-SDL2-head.patch
diff --git a/debian/upstream/metadata b/debian/upstream/metadata
index d73e564..a172346 100644
--- a/debian/upstream/metadata
+++ b/debian/upstream/metadata
@@ -1 +1,4 @@
-Repository: https://github.com/blupi-games/planetblupi
+Bug-Database: https://github.com/blupi-games/planetblupi/issues
+Bug-Submit: https://github.com/blupi-games/planetblupi/issues/new
+Repository: https://github.com/blupi-games/planetblupi.git
+Repository-Browse: https://github.com/blupi-games/planetblupi