summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Shadura <andrew.shadura@collabora.co.uk>2020-03-10 18:01:47 +0100
committerAndrej Shadura <andrew.shadura@collabora.co.uk>2020-03-10 18:49:38 +0100
commit16b141eebd21209d64beeddc8e58bf988cdca331 (patch)
tree0be427e58f31b2eb9f706d227d7f66ccab93af21
parent9ad3f155d71c197ea129fa08a3da00996d134aa4 (diff)
Generate the manpage from the POD source at build time
-rw-r--r--debian/clean1
-rw-r--r--debian/plantuml.181
-rw-r--r--debian/plantuml.pod174
-rwxr-xr-xdebian/rules5
4 files changed, 179 insertions, 82 deletions
diff --git a/debian/clean b/debian/clean
index 20d5925..690aeb1 100644
--- a/debian/clean
+++ b/debian/clean
@@ -1 +1,2 @@
plantuml.jar
+debian/plantuml.1
diff --git a/debian/plantuml.1 b/debian/plantuml.1
deleted file mode 100644
index 376bfa9..0000000
--- a/debian/plantuml.1
+++ /dev/null
@@ -1,81 +0,0 @@
-.TH PLANTUML 1 "March 8, 2010"
-.SH NAME
-plantuml \- program to generate UML diagram from a text description
-.SH SYNOPSIS
-.B plantuml
-.RI [ options ] " files/dirs" ...
-.SH DESCRIPTION
-\fIPlantUML\fP is used to draw UML diagram, using a simple and human readable text description.
-.PP
-Notice that \fBgraphviz\fP is required to be installed for generation of all
-diagrams but sequence diagrams.
-.PP
-When files/directories are given, they are processed in batch mode. Otherwise GUI
-window appears. It allows user to browse directories and view diagrams generated
-from suitable files (must have one of the following extensions: \fI.txt\fP,
-\fI.tex\fP, \fI.java\fP, \fI.htm\fP, \fI.html\fP, \fI.c\fP, \fI.h\fP, \fI.cpp\fP).
-.PP
-You can use the following wildcards in files/dirs:
-.TP
-.B *
-means any characters but '/'
-.TP
-.B ?
-one and only one character but '/'
-.TP
-.B **
-means any characters (used to recurse through directories)
-.SH OPTIONS
-.TP
-.B \-tsvg
-Generate images using SVG format.
-.TP
-\fB\-output\fI dir\fP, \fB\-o\fI dir
-Generate images in the specified directory.
-.TP
-\fB\-config\fI file
-Read the provided config file before each diagram.
-.TP
-\fB\-charset\fI xxx
-Use a specific charset (default is UTF\-8).
-.TP
-\fB\-exclude\fI pattern\fP, \fB\-x\fI pattern
-Exclude files that match the provided pattern.
-.TP
-.B \-metadata
-Retrieve \fIPlantUML\fP sources from PNG images.
-.TP
-.B \-version
-Display information about \fIPlantUML\fP and Java versions.
-.TP
-\fB\-verbose\fP, \fB\-v
-Have log information.
-.TP
-.B \-keepfiles
-NOT delete temporary files after process.
-.TP
-\fB\-help\fP, \fB\-h
-Display help message.
-.TP
-.B \-testdot
-Test the installation of \fBgraphviz\fP.
-.TP
-\fB\-graphvizdot\fI path
-Specify dot path.
-.TP
-\fB\-pipe\fP, \fB\-p
-Use stdin for \fIPlantUML\fP source and stdout for PNG/SVG generation.
-.TP
-.B \-computeurl
-Compute the encoded URL of a \fIPlantUML\fP source file.
-.TP
-.B \-decodeurl
-Retrieve the \fIPlantUML\fP source from an encoded URL.
-.SH SEE ALSO
-.BR graphviz (1).
-.br
-.SH AUTHOR
-\fIPlantUML\fP was written by Arnaud Roques <plantuml@gmail.com>.
-.PP
-This manual page was written by Ilya Paramonov <ivparamonov@gmail.com>,
-for the Debian project (and may be used by others).
diff --git a/debian/plantuml.pod b/debian/plantuml.pod
new file mode 100644
index 0000000..7d27289
--- /dev/null
+++ b/debian/plantuml.pod
@@ -0,0 +1,174 @@
+=head1 NAME
+
+plantuml - generate UML diagrams from a text description
+
+=head1 SYNOPSIS
+
+B<plantuml> [I<options>] I<files/dirs>...
+
+=head1 DESCRIPTION
+
+I<PlantUML> is used to draw UML diagrams using a simple and human
+readable text description.
+
+Note that B<graphviz> is required to be installed for generation of
+all diagrams except sequence diagrams.
+
+When files/directories are given, they are processed in batch mode.
+Otherwise, a GUI window appears. It allows user to browse directories and
+view diagrams generated from suitable files (must have one of the
+following extensions: I<.txt>, I<.tex>, I<.java>, I<.htm>, I<.html>, I<.c>,
+I<.h>, I<.cpp>).
+
+You can use the following wildcards in files/dirs:
+
+=over
+
+=item B<*>
+means any characters but '/'
+
+=item B<?>
+one and only one character but '/'
+
+=item B<**>
+means any characters (used to recurse through directories)
+
+=back
+
+=head1 OPTIONS
+
+=over
+
+=item B<-t>I<format>
+
+Generate images in one of the following formats:
+
+=over
+
+=item B<png>
+PNG image (default)
+
+=item B<svg>
+SVG image
+
+=item B<eps>
+EPS image
+
+=item B<pdf>
+PDF image
+
+=item B<vdx>
+VDX image
+
+=item B<xmi>
+XMI file for class diagram
+
+=item B<scxml>
+SCXML file for state diagram
+
+=item B<html>
+HTML file for class diagram
+
+=item B<txt>
+ASCII art
+
+=item B<utxt>
+ASCII art using Unicode characters
+
+=item B<latex>
+LaTeX/TikZ format
+
+=item B<latex:nopreamble>
+LaTeX/TikZ format without preamble
+
+=back
+
+=item B<-output> I<dir>, B<-o> I<dir>
+
+Generate images in the specified directory.
+
+=item B<-config> I<file>
+
+Read the provided config file before each diagram.
+
+=item B<-charset> I<encoding>
+
+Use a specific encoding (default is UTF-8).
+
+=item B<-exclude> I<pattern>, B<-x> I<pattern>
+
+Exclude files that match the provided pattern.
+
+=item B<-metadata>
+
+Retrieve I<PlantUML sources from PNG images.>
+
+=item B<-version>
+
+Display information about I<PlantUML and Java versions.>
+
+=item B<-verbose>, B<-v>
+
+Be more verbose.
+
+=item B<-quiet>
+
+Don't print error messages.
+
+=item B<-keepfiles>
+
+Do NOT delete temporary files after process.
+
+=item B<-help>, B<-h>
+Display a help message.
+
+=item B<-testdot>
+Test the installation of B<graphviz>.
+
+=item B<-graphvizdot> I<path>
+Specify the B<dot> executable path.
+
+=item B<-pipe>, B<-p>
+Use stdin for I<PlantUML> source and stdout for PNG/SVG
+generation.
+
+=item B<-computeurl>
+Compute the encoded URL of a I<PlantUML> source file.
+
+=item B<-decodeurl>
+Retrieve the I<PlantUML> source from an encoded URL.
+
+=back
+
+This list of options is not exhaustive. For more information, run B<plantuml -help>.
+
+For more documentation, see the I<PlantUML>'s website: L<< https://plantuml.com/command-line >>.
+
+=head1 ENVIRONMENT
+
+=over
+
+=item I<DISPLAY>
+
+If not set or empty, uses Java's headless mode to run I<PlantUML>.
+
+=item I<GRAPHVIZ_DOT>
+
+Similarly to B<-graphvizdot>, can be used to specify the path to the B<dot> executable. If both I<GRAPHVIZ_DOT> and B<-graphvizdot> are used, the command-line setting takes the precedence.
+
+=back
+
+=head1 NOTES
+
+The Debian package for I<PlantUML> comes without Easter eggs, XEarth diagram support or inbuilt FTP server, Telnet server or a Sudoku game.
+
+=head1 SEE ALSO
+
+L<graphviz(1)>
+
+=head1 AUTHOR
+
+I<PlantUML> was written by Arnaud Roques L<< <plantuml@gmail.com> >>.
+
+This manual page was written by Ilya Paramonov L<< <ivparamonov@gmail.com> >>
+and updated by Andrej Shadura L<< <andrewsh@debian.org> >>, for the Debian project (and may be used by others).
diff --git a/debian/rules b/debian/rules
index bb2b2b1..fd30936 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,7 +6,10 @@
override_dh_auto_clean:
rm -rf build dist
-override_dh_auto_build:
+%.1: %.pod
+ pod2man -c "" -d $$(date -u -d "$$(dpkg-parsechangelog -S Date)" +%F) -r "" $< > $@
+
+override_dh_auto_build: debian/plantuml.1
dh_auto_build -- dist
override_dh_auto_install: