summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Boot <bootc@debian.org>2018-11-04 12:56:54 +0000
committerChris Boot <bootc@debian.org>2018-11-04 12:56:54 +0000
commita259c2fa88e0fb92ee29823eb0e588d5169a55cd (patch)
tree6d0503ee1d515b12c83583aa17e8562ed3c0084e
parentbef4e99df0f0b52690878961d3eb9bcc72d63a03 (diff)
Add a SONAME to the pppd binary
This hack inserts a SONAME into the pppd binary, which allows us to run dpkg-gensymbols/dh_makeshlibs over the resulting binary. This is useful so that we can use Debian's standard build infrastructure to help track the ppp binary's ABI, which is used by plugins. Forwarded: not-needed Last-Update: 2015-12-05 Gbp-Pq: Name pppd-soname-hack.patch
-rw-r--r--pppd/Makefile.linux5
1 files changed, 4 insertions, 1 deletions
diff --git a/pppd/Makefile.linux b/pppd/Makefile.linux
index a90cbdc..f1b2c90 100644
--- a/pppd/Makefile.linux
+++ b/pppd/Makefile.linux
@@ -206,6 +206,8 @@ endif
INSTALL= install
+VERSION = $(shell awk -F '"' '/VERSION/ { print $$2; }' patchlevel.h)
+
all: $(TARGETS)
install: pppd
@@ -217,7 +219,8 @@ install: pppd
$(INSTALL) -c -m 444 pppd.8 $(MANDIR)
pppd: $(PPPDOBJS)
- $(CC) $(LDFLAGS) -o pppd $(PPPDOBJS) $(LIBS)
+ $(CC) $(LDFLAGS) -o pppd $(PPPDOBJS) $(LIBS) \
+ -Wl,-soname,pppd.so.$(VERSION)
srp-entry: srp-entry.c
$(CC) $(CFLAGS) $(LDFLAGS) -o $@ srp-entry.c $(LIBS)