summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndy Li <andy@onthewings.net>2018-12-26 01:02:33 +0800
committerAndy Li <andy@onthewings.net>2018-12-26 01:03:56 +0800
commitfba00138c5e0058b03f11aad610689ea32511341 (patch)
tree1f811f5fa6391a3e744fef514e0f9bb9c113bd76
parenteeeee762a4255f53620c5dd80756ffe23e4ff2e3 (diff)
fix autopkgtest
-rw-r--r--debian/changelog1
-rwxr-xr-xdebian/tests/ppx-once4
2 files changed, 3 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index bdb0259..9dc4c63 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,7 @@ ppx-tools-versioned (5.2.1-1) unstable; urgency=medium
* New upstream release.
* Update d/rules regarding changes to dune.
* Bump Standards-Version to 4.3.0 (no changes).
+ * Fix autopkgtest.
-- Andy Li <andy@onthewings.net> Wed, 26 Dec 2018 00:38:42 +0800
diff --git a/debian/tests/ppx-once b/debian/tests/ppx-once
index 15ea594..ad3f6e3 100755
--- a/debian/tests/ppx-once
+++ b/debian/tests/ppx-once
@@ -6,9 +6,9 @@ cd "$(dirname "$0")/../../example/ppx_once"
if [ -x '/usr/bin/ocamlopt' ]
then
- make
+ make "FLAGS=-package ocaml-migrate-parsetree,ppx_tools_versioned.metaquot_405,ppx_tools_versioned"
else
- make ppx_once.cmo
+ make ppx_once.cmo "FLAGS=-package ocaml-migrate-parsetree,ppx_tools_versioned.metaquot_405,ppx_tools_versioned"
fi
make clean