summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2014-05-17 16:43:36 -0400
committerJoey Hess <joey@kitenet.net>2014-05-17 16:43:36 -0400
commitd1d94fa1ea1cdea28298b935f53e59dca36b31c8 (patch)
treec3f95f061f73dd865ba3795b68573973d26a0b83
parent39217c55690de5641a9fe4ef2236d6127ebbcbb3 (diff)
parentc09babd5b7cb059cc9fa5ffb2ddfa4255e21e321 (diff)
Merge branch 'joeyconfig'
-rw-r--r--config-joey.hs16
-rw-r--r--debian/changelog10
-rw-r--r--propellor.cabal2
3 files changed, 25 insertions, 3 deletions
diff --git a/config-joey.hs b/config-joey.hs
index 769357ce..9278808c 100644
--- a/config-joey.hs
+++ b/config-joey.hs
@@ -252,6 +252,22 @@ image (System (Debian Unstable) arch) = "joeyh/debian-unstable-" ++ arch
image (System (Debian Stable) arch) = "joeyh/debian-stable-" ++ arch
image _ = "debian-stable-official" -- does not currently exist!
+-- Digital Ocean does not provide any way to boot
+-- the kernel provided by the distribution, except using kexec.
+-- Without this, some old, and perhaps insecure kernel will be used.
+--
+-- Note that this only causes the new kernel to be loaded on reboot.
+-- If the power is cycled, the old kernel still boots up.
+-- TODO: detect this and reboot immediately?
+digitalOceanDistroKernel :: Property
+digitalOceanDistroKernel = propertyList "digital ocean distro kernel hack"
+ [ Apt.installed ["grub-pc", "kexec-tools"]
+ , "/etc/default/kexec" `File.containsLines`
+ [ "LOAD_KEXEC=true"
+ , "USE_GRUB_CONFIG=true"
+ ]
+ ]
+
-- Clean up a system as installed by cloudatcost.com
cleanCloudAtCost :: Property
cleanCloudAtCost = propertyList "cloudatcost cleanup"
diff --git a/debian/changelog b/debian/changelog
index 7a06e2f9..16ababc2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,14 @@
-propellor (0.5.2) UNRELEASED; urgency=medium
+propellor (0.5.2) unstable; urgency=medium
+ * A bug that caused propellor to hang when updating a running docker
+ container appears to have been fixed. Note that since it affects
+ the propellor process that serves as "init" of docker containers,
+ they have to be restarted for the fix to take effect.
* Licence changed from GPL to BSD.
+ * A few changes to allow building Propellor on OSX. One user reports
+ successfully using it there.
- -- Joey Hess <joeyh@debian.org> Sat, 10 May 2014 11:05:19 -0300
+ -- Joey Hess <joeyh@debian.org> Sat, 17 May 2014 16:42:55 -0400
propellor (0.5.1) unstable; urgency=medium
diff --git a/propellor.cabal b/propellor.cabal
index 55b7eb60..9d0612e9 100644
--- a/propellor.cabal
+++ b/propellor.cabal
@@ -1,5 +1,5 @@
Name: propellor
-Version: 0.5.1
+Version: 0.5.2
Cabal-Version: >= 1.6
License: BSD
Maintainer: Joey Hess <joey@kitenet.net>