summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules20
1 files changed, 20 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..61fe338
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,20 @@
+#!/usr/bin/make -f
+
+export CFLAGS := $(shell dpkg-buildflags --get CFLAGS) $(shell dpkg-buildflags --get CPPFLAGS) $(shell dpkg-buildflags --get LDFLAGS)
+
+%:
+ dh $@
+
+override_dh_auto_configure:
+ ./configure --prefix=/usr --bits=$(shell dpkg-architecture -qDEB_HOST_ARCH_BITS) --libdir=/usr/lib/$(shell dpkg-architecture -qDEB_HOST_MULTIARCH)/pseudo --without-rpath
+
+override_dh_auto_install:
+ dh_auto_install
+ rm -r debian/*/usr/var
+
+override_dh_auto_test:
+ unset LD_PRELOAD; \
+ dh_auto_test
+
+override_dh_installchangelogs:
+ dh_installchangelogs ChangeLog.txt