summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelipe Sateler <fsateler@debian.org>2019-10-25 08:45:51 -0300
committerFelipe Sateler <fsateler@debian.org>2019-10-25 08:45:52 -0300
commit42c13a62424ef5c6a777be88841ebb925baabc45 (patch)
treeb0d200274d722715967384b865706df4b119b049
parentafe990e01a5f93009bbd813050cfc13b5f2ffaf2 (diff)
qpaeq: migrate to python3
Patch picked from Fedora and cleaned up for upstream inclusion. Closes: #937338
-rw-r--r--debian/control2
-rw-r--r--debian/patches/qpaeq-Drop-unused-imports.patch22
-rw-r--r--debian/patches/qpaeq-use-python3-instead-of-python-2.patch20
-rw-r--r--debian/patches/series2
4 files changed, 45 insertions, 1 deletions
diff --git a/debian/control b/debian/control
index 781839c..46951c6 100644
--- a/debian/control
+++ b/debian/control
@@ -180,7 +180,7 @@ Description: Bluetooth module for PulseAudio sound server
Package: pulseaudio-equalizer
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends},
- python, python-pyqt5, python-sip, python-dbus.mainloop.pyqt5, python-dbus
+ python3, python3-pyqt5, python3-dbus.mainloop.pyqt5, python3-dbus
Description: Equalizer sink module for PulseAudio sound server
PulseAudio, previously known as Polypaudio, is a sound server for POSIX and
WIN32 systems. It is a drop in replacement for the ESD sound server with
diff --git a/debian/patches/qpaeq-Drop-unused-imports.patch b/debian/patches/qpaeq-Drop-unused-imports.patch
new file mode 100644
index 0000000..823ba81
--- /dev/null
+++ b/debian/patches/qpaeq-Drop-unused-imports.patch
@@ -0,0 +1,22 @@
+From: Felipe Sateler <fsateler@debian.org>
+Date: Fri, 25 Oct 2019 08:34:59 -0300
+Subject: qpaeq: Drop unused imports
+
+Neither sip nor PyQt5 are used. From PyQt5 we only use the named imports just below
+Forwarded: https://gitlab.freedesktop.org/pulseaudio/pulseaudio/merge_requests/197
+---
+ src/utils/qpaeq | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/src/utils/qpaeq b/src/utils/qpaeq
+index ac0daec..914aedf 100755
+--- a/src/utils/qpaeq
++++ b/src/utils/qpaeq
+@@ -18,7 +18,6 @@
+
+ import os,math,sys
+ try:
+- import PyQt5,sip
+ from PyQt5 import QtWidgets,QtCore
+ import dbus.mainloop.pyqt5
+ import dbus
diff --git a/debian/patches/qpaeq-use-python3-instead-of-python-2.patch b/debian/patches/qpaeq-use-python3-instead-of-python-2.patch
new file mode 100644
index 0000000..9abe160
--- /dev/null
+++ b/debian/patches/qpaeq-use-python3-instead-of-python-2.patch
@@ -0,0 +1,20 @@
+From: Felipe Sateler <fsateler@debian.org>
+Date: Fri, 25 Oct 2019 08:39:03 -0300
+Subject: qpaeq: use python3 instead of python 2
+
+The script was already compatible, so lets just switch interpreter
+Forwarded: https://gitlab.freedesktop.org/pulseaudio/pulseaudio/merge_requests/197
+---
+ src/utils/qpaeq | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/utils/qpaeq b/src/utils/qpaeq
+index 914aedf..7e01d87 100755
+--- a/src/utils/qpaeq
++++ b/src/utils/qpaeq
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ # qpaeq is a equalizer interface for pulseaudio's equalizer sinks
+ # Copyright (C) 2009 Jason Newton <nevion@gmail.com
+ #
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..4cfd5a4
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,2 @@
+qpaeq-Drop-unused-imports.patch
+qpaeq-use-python3-instead-of-python-2.patch