summaryrefslogtreecommitdiff
path: root/man
diff options
context:
space:
mode:
authorFelipe Sateler <fsateler@debian.org>2016-05-13 20:52:16 -0300
committerFelipe Sateler <fsateler@debian.org>2016-05-13 20:52:16 -0300
commite8f565a24d9a69ae696f0600f2ea992ddbd9f7c6 (patch)
tree16aaf7ab080b2f314fe3a239774e8f3768bfcfe8 /man
parentae999803298bb86b891d5ecefb5672e199a8ff2b (diff)
Imported Upstream version 8.99.1
Diffstat (limited to 'man')
-rw-r--r--man/Makefile.in4
-rw-r--r--man/pulse-client.conf.54
-rw-r--r--man/pulse-client.conf.5.xml.in8
-rw-r--r--man/pulse-daemon.conf.54
-rw-r--r--man/pulse-daemon.conf.5.xml.in7
-rw-r--r--man/pulseaudio.15
-rw-r--r--man/pulseaudio.1.xml.in15
7 files changed, 40 insertions, 7 deletions
diff --git a/man/Makefile.in b/man/Makefile.in
index fbc46a5..648dc7a 100644
--- a/man/Makefile.in
+++ b/man/Makefile.in
@@ -108,6 +108,8 @@ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
am__aclocal_m4_deps = $(top_srcdir)/m4/acx_libwrap.m4 \
$(top_srcdir)/m4/ax_check_define.m4 \
$(top_srcdir)/m4/ax_check_flag.m4 \
+ $(top_srcdir)/m4/ax_cxx_compile_stdcxx.m4 \
+ $(top_srcdir)/m4/ax_cxx_compile_stdcxx_11.m4 \
$(top_srcdir)/m4/ax_define_dir.m4 \
$(top_srcdir)/m4/ax_pthread.m4 $(top_srcdir)/m4/ax_tls.m4 \
$(top_srcdir)/m4/gettext.m4 $(top_srcdir)/m4/iconv.m4 \
@@ -260,8 +262,10 @@ HAVE_BLUEZ_5 = @HAVE_BLUEZ_5@
HAVE_BLUEZ_5_NATIVE_HEADSET = @HAVE_BLUEZ_5_NATIVE_HEADSET@
HAVE_BLUEZ_5_OFONO_HEADSET = @HAVE_BLUEZ_5_OFONO_HEADSET@
HAVE_COREAUDIO = @HAVE_COREAUDIO@
+HAVE_CXX11 = @HAVE_CXX11@
HAVE_DBUS = @HAVE_DBUS@
HAVE_GLIB20 = @HAVE_GLIB20@
+HAVE_MEMFD = @HAVE_MEMFD@
HAVE_MKFIFO = @HAVE_MKFIFO@
HAVE_NEON = @HAVE_NEON@
HAVE_OSS_OUTPUT = @HAVE_OSS_OUTPUT@
diff --git a/man/pulse-client.conf.5 b/man/pulse-client.conf.5
index 8b8a959..5c4b515 100644
--- a/man/pulse-client.conf.5
+++ b/man/pulse-client.conf.5
@@ -32,7 +32,9 @@ For the settings that take a boolean argument the values \fBtrue\f1, \fByes\f1,
.TP
\fBcookie-file=\f1 Specify the path to the PulseAudio authentication cookie. Defaults to \fI~/.config/pulse/cookie\f1.
.TP
-\fBenable-shm=\f1 Enable data transfer via POSIX shared memory. Takes a boolean argument, defaults to \fByes\f1.
+\fBenable-shm=\f1 Enable data transfer via POSIX or memfd shared memory. Takes a boolean argument, defaults to \fByes\f1. If set to \fBno\f1, communication with the server will be exclusively done through data-copy over sockets.
+.TP
+\fBenable-memfd=\f1. Enable data transfer via memfd shared memory. Takes a boolean argument, defaults to \fByes\f1.
.TP
\fBshm-size-bytes=\f1 Sets the shared memory segment size for clients, in bytes. If left unspecified or is set to 0 it will default to some system-specific default, usually 64 MiB. Please note that usually there is no need to change this value, unless you are running an OS kernel that does not do memory overcommit.
.TP
diff --git a/man/pulse-client.conf.5.xml.in b/man/pulse-client.conf.5.xml.in
index cca2219..b88898c 100644
--- a/man/pulse-client.conf.5.xml.in
+++ b/man/pulse-client.conf.5.xml.in
@@ -102,6 +102,14 @@ License along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.
<option>
<p><opt>enable-shm=</opt> Enable data transfer via POSIX
+ or memfd shared memory. Takes a boolean argument, defaults to
+ <opt>yes</opt>. If set to <opt>no</opt>, communication with
+ the server will be exclusively done through data-copy over
+ sockets.</p>
+ </option>
+
+ <option>
+ <p><opt>enable-memfd=</opt>. Enable data transfer via memfd
shared memory. Takes a boolean argument, defaults to
<opt>yes</opt>.</p>
</option>
diff --git a/man/pulse-daemon.conf.5 b/man/pulse-daemon.conf.5
index 1bac86d..d1b71c6 100644
--- a/man/pulse-daemon.conf.5
+++ b/man/pulse-daemon.conf.5
@@ -44,7 +44,9 @@ For the settings that take a boolean argument the values \fBtrue\f1, \fByes\f1,
.TP
\fBlocal-server-type=\f1 Please don't use this option if you don't have to! This option is currently only useful when you want D-Bus clients to use a remote server. This option may be removed in future versions. If you only want to run PulseAudio in the system mode, use the \fBsystem-instance\f1 option. This option takes one of \fBuser\f1, \fBsystem\f1 or \fBnone\f1 as the argument. This is essentially a duplicate for the \fBsystem-instance\f1 option. The difference is the \fBnone\f1 option, which is useful when you want to use a remote server with D-Bus clients. If both this and \fBsystem-instance\f1 are defined, this option takes precedence. Defaults to whatever the \fBsystem-instance\f1 is set.
.TP
-\fBenable-shm=\f1 Enable data transfer via POSIX shared memory. Takes a boolean argument, defaults to \fByes\f1. The \fB--disable-shm\f1 command line argument takes precedence.
+\fBenable-shm=\f1 Enable data transfer via POSIX or memfd shared memory. Takes a boolean argument, defaults to \fByes\f1. The \fB--disable-shm\f1 command line argument takes precedence.
+.TP
+\fBenable-memfd=\f1. Enable memfd shared memory. Takes a boolean argument, defaults to \fBno\f1.
.TP
\fBshm-size-bytes=\f1 Sets the shared memory segment size for the daemon, in bytes. If left unspecified or is set to 0 it will default to some system-specific default, usually 64 MiB. Please note that usually there is no need to change this value, unless you are running an OS kernel that does not do memory overcommit.
.TP
diff --git a/man/pulse-daemon.conf.5.xml.in b/man/pulse-daemon.conf.5.xml.in
index 0367b1f..1abc94f 100644
--- a/man/pulse-daemon.conf.5.xml.in
+++ b/man/pulse-daemon.conf.5.xml.in
@@ -189,12 +189,17 @@ License along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.
<option>
<p><opt>enable-shm=</opt> Enable data transfer via POSIX
- shared memory. Takes a boolean argument, defaults to
+ or memfd shared memory. Takes a boolean argument, defaults to
<opt>yes</opt>. The <opt>--disable-shm</opt> command line
argument takes precedence.</p>
</option>
<option>
+ <p><opt>enable-memfd=</opt>. Enable memfd shared memory. Takes
+ a boolean argument, defaults to <opt>no</opt>.</p>
+ </option>
+
+ <option>
<p><opt>shm-size-bytes=</opt> Sets the shared memory segment
size for the daemon, in bytes. If left unspecified or is set to 0
it will default to some system-specific default, usually 64
diff --git a/man/pulseaudio.1 b/man/pulseaudio.1
index 60eb94e..a66d7be 100644
--- a/man/pulseaudio.1
+++ b/man/pulseaudio.1
@@ -111,7 +111,10 @@ Create a PID file. If this options is disabled it is possible to run multiple so
Do not install CPU load limiter on platforms that support it. By default, PulseAudio will terminate itself when it notices that it takes up too much CPU time. This is useful as a protection against system lockups when real-time scheduling is used (see below). Disabling this mechanism is useful when debugging PulseAudio with tools like \fBvalgrind(1)\f1 which slow down execution.
.TP
\fB--disable-shm\f1\fI[=BOOL]\f1
-PulseAudio clients and the server can exchange audio data via POSIX shared memory segments (on systems that support this). If disabled PulseAudio will communicate exclusively over sockets. Please note that data transfer via shared memory segments is always disabled when PulseAudio is running with \fB--system\f1 enabled (see above).
+PulseAudio clients and the server can exchange audio data via POSIX or memfd shared memory segments (on systems that support this). If disabled PulseAudio will communicate exclusively over sockets. Please note that data transfer via shared memory segments is always disabled when PulseAudio is running with \fB--system\f1 enabled (see above).
+.TP
+\fB--enable-memfd\f1\fI[=BOOL]\f1
+PulseAudio clients and the server can exchange audio data via memfds - the anonymous Linux Kernel shared memory mechanism (on kernels that support this). If disabled PulseAudio will communicate via POSIX shared memory.
.TP
\fB-L | --load\f1\fI="MODULE ARGUMENTS"\f1
Load the specified plugin module with the specified arguments.
diff --git a/man/pulseaudio.1.xml.in b/man/pulseaudio.1.xml.in
index 650b417..3187ef5 100644
--- a/man/pulseaudio.1.xml.in
+++ b/man/pulseaudio.1.xml.in
@@ -292,14 +292,23 @@ License along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.
<p><opt>--disable-shm</opt><arg>[=BOOL]</arg></p>
<optdesc><p>PulseAudio clients and the server can exchange audio
- data via POSIX shared memory segments (on systems that support
- this). If disabled PulseAudio will communicate exclusively over
- sockets. Please note that data transfer via shared memory
+ data via POSIX or memfd shared memory segments (on systems that
+ support this). If disabled PulseAudio will communicate exclusively
+ over sockets. Please note that data transfer via shared memory
segments is always disabled when PulseAudio is running with
<opt>--system</opt> enabled (see above).</p></optdesc>
</option>
<option>
+ <p><opt>--enable-memfd</opt><arg>[=BOOL]</arg></p>
+
+ <optdesc><p>PulseAudio clients and the server can exchange audio
+ data via memfds - the anonymous Linux Kernel shared memory mechanism
+ (on kernels that support this). If disabled PulseAudio will
+ communicate via POSIX shared memory.</p></optdesc>
+ </option>
+
+ <option>
<p><opt>-L | --load</opt><arg>="MODULE ARGUMENTS"</arg></p>
<optdesc><p>Load the specified plugin module with the specified