summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
authorAlexander Zhukov <zhukovaa90@gmail.com>2016-10-12 17:52:30 +0300
committerAlexander Zhukov <zhukovaa90@gmail.com>2016-10-13 17:36:29 +0300
commitafb6b5da48d891dd5feb0512559990eb3c189e4c (patch)
tree6549a4e822186fb61999bf500645ea4e7dcab3c7 /.travis.yml
parent2ee1faab7864a0e8ba90aacffcde21d26bf4e242 (diff)
Update .travis.yml
Diffstat (limited to '.travis.yml')
-rwxr-xr-x.travis.yml20
1 files changed, 17 insertions, 3 deletions
diff --git a/.travis.yml b/.travis.yml
index 6c10778..78b2959 100755
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,13 +1,27 @@
language: python
python:
+ - 2.6
- 2.7
+ - 3.2
+ - 3.3
- 3.5
+ - 3.6-dev
- nightly
+
+env:
+ - LMDB_FORCE_CFFI=1
+ -
install:
- - "python setup.py install"
-setup:
+ - "pip install cffi"
+
+ # this is a workaround for https://github.com/dw/py-lmdb/issues/132
+ - "git revert --no-commit 04ef5846262d9bee39938208af14cce28ebc1834"
+
+ - "python setup.py install"
+before_script:
+
script:
- - "python -m pytest tests"
+ - "py.test tests"
notifications:
email: false