summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2017-11-11 12:55:26 +0000
committerColin Watson <cjwatson@debian.org>2017-11-11 12:55:26 +0000
commit33f68384774e4c9b0bc11389b1559ec9b0cb41b5 (patch)
tree74fcbacf5cae4f47ff4af51a16877ba865a9b374
parentfdd77e9218bb3d7a4c6bbdb378c9681e4a11aed3 (diff)
parent530e1e702c8743fc8ea93db035bf86f6c07e6d09 (diff)
New upstream release (0.0.6)
-rw-r--r--debian/.git-dpm14
-rw-r--r--debian/changelog6
-rw-r--r--debian/patches/isolate-from-proxy.patch2
-rwxr-xr-xdocs/conf.py2
-rw-r--r--macaroonbakery/httpbakery/agent/agent.py9
-rwxr-xr-xsetup.py2
6 files changed, 22 insertions, 13 deletions
diff --git a/debian/.git-dpm b/debian/.git-dpm
index 865a7b9..eb270f8 100644
--- a/debian/.git-dpm
+++ b/debian/.git-dpm
@@ -1,11 +1,11 @@
# see git-dpm(1) from git-dpm package
-8051fc0e07186078ae5419ac9de246cf6e57359a
-8051fc0e07186078ae5419ac9de246cf6e57359a
-37d61d0415f6cc96a7a9abe057e1ae0f89fd977e
-37d61d0415f6cc96a7a9abe057e1ae0f89fd977e
-py-macaroon-bakery_0.0.5.orig.tar.gz
-b6a1d6a8ff0cc252cf2dd3464bb881daadb7b056
-80202
+530e1e702c8743fc8ea93db035bf86f6c07e6d09
+530e1e702c8743fc8ea93db035bf86f6c07e6d09
+949b7072cabce0daed6c94993ad44c8ea8648dbd
+949b7072cabce0daed6c94993ad44c8ea8648dbd
+py-macaroon-bakery_0.0.6.orig.tar.gz
+840f786baa4226742e0c709fafc8422aac59a92b
+80215
debianTag="debian/%e%v"
patchedTag="patched/%e%v"
upstreamTag="upstream/%e%u"
diff --git a/debian/changelog b/debian/changelog
index 4270b39..f9930a5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+py-macaroon-bakery (0.0.6-1) UNRELEASED; urgency=medium
+
+ * New upstream release.
+
+ -- Colin Watson <cjwatson@debian.org> Sat, 11 Nov 2017 12:55:06 +0000
+
py-macaroon-bakery (0.0.5-1) unstable; urgency=medium
* New upstream release.
diff --git a/debian/patches/isolate-from-proxy.patch b/debian/patches/isolate-from-proxy.patch
index ee5d08a..89d7af6 100644
--- a/debian/patches/isolate-from-proxy.patch
+++ b/debian/patches/isolate-from-proxy.patch
@@ -1,4 +1,4 @@
-From 8051fc0e07186078ae5419ac9de246cf6e57359a Mon Sep 17 00:00:00 2001
+From 530e1e702c8743fc8ea93db035bf86f6c07e6d09 Mon Sep 17 00:00:00 2001
From: Colin Watson <cjwatson@debian.org>
Date: Mon, 6 Nov 2017 10:27:10 +0000
Subject: Isolate client tests from any HTTP proxy
diff --git a/docs/conf.py b/docs/conf.py
index df296f1..a64ec3a 100755
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -63,7 +63,7 @@ copyright = u'2017, Juju UI Team'
# the built documents.
#
# The short X.Y version and the full version.
-version = release = '0.0.4'
+version = release = '0.0.6'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/macaroonbakery/httpbakery/agent/agent.py b/macaroonbakery/httpbakery/agent/agent.py
index 862f00e..ad56015 100644
--- a/macaroonbakery/httpbakery/agent/agent.py
+++ b/macaroonbakery/httpbakery/agent/agent.py
@@ -6,6 +6,7 @@ import json
import nacl.public
import nacl.encoding
+import nacl.exceptions
import requests.cookies
import six
from six.moves.urllib.parse import urlparse
@@ -35,8 +36,10 @@ def load_agent_file(filename, cookies=None):
with open(filename) as f:
data = json.load(f)
try:
- key = nacl.public.PrivateKey(data['key']['private'],
- nacl.encoding.Base64Encoder)
+ key = nacl.public.PrivateKey(
+ data['key']['private'],
+ nacl.encoding.Base64Encoder,
+ )
if cookies is None:
cookies = requests.cookies.RequestsCookieJar()
for agent in data['agents']:
@@ -54,7 +57,7 @@ def load_agent_file(filename, cookies=None):
path=u.path)
cookies.set_cookie(cookie)
return cookies, key
- except (KeyError, ValueError) as e:
+ except (KeyError, ValueError, nacl.exceptions.TypeError) as e:
raise AgentFileFormatError('invalid agent file', e)
diff --git a/setup.py b/setup.py
index 340bf3a..40155f9 100755
--- a/setup.py
+++ b/setup.py
@@ -12,7 +12,7 @@ from setuptools import (
PROJECT_NAME = 'macaroonbakery'
-VERSION = (0, 0, 5)
+VERSION = (0, 0, 6)
def get_version():