summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2017-11-03 16:10:44 +0000
committerColin Watson <cjwatson@debian.org>2017-11-03 16:11:17 +0000
commit8181f6fcb5bc7683142f152358a183d808191b60 (patch)
treed0ca257023ffdc4cbf8fc4e7e131914d756c7628
parentc5a506f9683bcc1d122b8d3b2999e82799a64faf (diff)
parent075e9d186663b19cc3d3a892377e28fcfd7993a7 (diff)
Cherry-pick https://github.com/go-macaroon-bakery/py-macaroon-bakery/pull/26 to lower protobuf and requests dependencies to versions satisfiable in unstable.
-rw-r--r--debian/.git-dpm4
-rw-r--r--debian/changelog4
-rw-r--r--debian/patches/lower-protobuf-requests-deps.patch32
-rw-r--r--debian/patches/series1
-rwxr-xr-xsetup.py4
5 files changed, 41 insertions, 4 deletions
diff --git a/debian/.git-dpm b/debian/.git-dpm
index 0e8f4a8..78ae886 100644
--- a/debian/.git-dpm
+++ b/debian/.git-dpm
@@ -1,6 +1,6 @@
# see git-dpm(1) from git-dpm package
-3d9eaeb5dacee168a93da090e2c0d46eedbe51a2
-3d9eaeb5dacee168a93da090e2c0d46eedbe51a2
+075e9d186663b19cc3d3a892377e28fcfd7993a7
+075e9d186663b19cc3d3a892377e28fcfd7993a7
3d9eaeb5dacee168a93da090e2c0d46eedbe51a2
3d9eaeb5dacee168a93da090e2c0d46eedbe51a2
py-macaroon-bakery_0.0.4.orig.tar.gz
diff --git a/debian/changelog b/debian/changelog
index 92170ca..a1bb32f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,10 @@
py-macaroon-bakery (0.0.4-1) UNRELEASED; urgency=medium
* New upstream release.
+ * Cherry-pick
+ https://github.com/go-macaroon-bakery/py-macaroon-bakery/pull/26 to
+ lower protobuf and requests dependencies to versions satisfiable in
+ unstable.
-- Colin Watson <cjwatson@debian.org> Fri, 03 Nov 2017 12:13:49 +0000
diff --git a/debian/patches/lower-protobuf-requests-deps.patch b/debian/patches/lower-protobuf-requests-deps.patch
new file mode 100644
index 0000000..112c9ba
--- /dev/null
+++ b/debian/patches/lower-protobuf-requests-deps.patch
@@ -0,0 +1,32 @@
+From 075e9d186663b19cc3d3a892377e28fcfd7993a7 Mon Sep 17 00:00:00 2001
+From: Andrea Azzarone <andrea.azzarone@canonical.com>
+Date: Fri, 3 Nov 2017 15:00:01 +0000
+Subject: Lowering the protobuf and requests deps.
+
+Origin: other, https://github.com/go-macaroon-bakery/py-macaroon-bakery/pull/26
+Forwarded: https://github.com/go-macaroon-bakery/py-macaroon-bakery/pull/26
+Patch-Name: lower-protobuf-requests-deps.patch
+
+Last-Update: 2017-11-03
+---
+ setup.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 7fbc6d3..54000e9 100755
+--- a/setup.py
++++ b/setup.py
+@@ -24,11 +24,11 @@ with open('README.rst') as readme_file:
+ readme = readme_file.read()
+
+ requirements = [
+- 'requests>=2.18.4,<3.0',
++ 'requests>=2.18.1,<3.0',
+ 'PyNaCl>=1.1.2,<2.0',
+ 'pymacaroons>=0.12.0,<1.0',
+ 'six>=1.11.0,<2.0',
+- 'protobuf>=3.4.0,<4.0',
++ 'protobuf>=3.0.0,<4.0',
+ 'pyRFC3339>=1.0,<2.0',
+ 'pytz>=2017.2,<2018.0'
+ ]
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..f688483
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+lower-protobuf-requests-deps.patch
diff --git a/setup.py b/setup.py
index 7fbc6d3..54000e9 100755
--- a/setup.py
+++ b/setup.py
@@ -24,11 +24,11 @@ with open('README.rst') as readme_file:
readme = readme_file.read()
requirements = [
- 'requests>=2.18.4,<3.0',
+ 'requests>=2.18.1,<3.0',
'PyNaCl>=1.1.2,<2.0',
'pymacaroons>=0.12.0,<1.0',
'six>=1.11.0,<2.0',
- 'protobuf>=3.4.0,<4.0',
+ 'protobuf>=3.0.0,<4.0',
'pyRFC3339>=1.0,<2.0',
'pytz>=2017.2,<2018.0'
]