summaryrefslogtreecommitdiff
path: root/debian/patches/avoid-deprecated-platform-dist.patch
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2019-12-26 22:45:38 +0000
committerColin Watson <cjwatson@debian.org>2019-12-26 22:45:38 +0000
commitbfaac8e7837fa1c08699594cfe9082df5c768bed (patch)
tree3fd89ace073ec8726d1570e039bc2abfa2a09431 /debian/patches/avoid-deprecated-platform-dist.patch
parent17b2ffceaf6e00834e982bfae18a37478eb01ec0 (diff)
Avoid using deprecated platform.dist() in setup.py
Diffstat (limited to 'debian/patches/avoid-deprecated-platform-dist.patch')
-rw-r--r--debian/patches/avoid-deprecated-platform-dist.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/debian/patches/avoid-deprecated-platform-dist.patch b/debian/patches/avoid-deprecated-platform-dist.patch
new file mode 100644
index 0000000..0bb3bd2
--- /dev/null
+++ b/debian/patches/avoid-deprecated-platform-dist.patch
@@ -0,0 +1,43 @@
+From: Francesco Banconi <francesco.banconi@canonical.com>
+Date: Mon, 13 May 2019 11:27:48 +0200
+Subject: Avoid using deprecated platform.dist() in setup.py
+
+Bug: https://github.com/go-macaroon-bakery/py-macaroon-bakery/issues/74
+Origin: upstream, https://github.com/go-macaroon-bakery/py-macaroon-bakery/commit/3721180c4a3765e8807392fca2b7e7c2d7ffae45
+Last-Update: 2019-12-26
+---
+ setup.py | 9 +++------
+ 1 file changed, 3 insertions(+), 6 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index f098e76..83aec8c 100755
+--- a/setup.py
++++ b/setup.py
+@@ -3,7 +3,6 @@
+ # Copyright 2017 Canonical Ltd.
+ # Licensed under the LGPLv3, see LICENCE file for details.
+ import sys
+-import platform
+
+ from setuptools import (
+ find_packages,
+@@ -39,16 +38,14 @@ test_requirements = [
+ 'httmock==1.2.5',
+ ]
+
+-distribution = platform.dist()
+-if len(distribution) == 3 and distribution[2] == 'trusty':
++if sys.version_info < (2, 7, 9):
+ # Injected into urllib3 to fix insecure Python 2.
+ requirements.extend([
+ 'cryptography==1.3.2',
+- 'pyOpenSSL==16.0.0',
+- 'pyasn1==0.1.9',
+ 'ndg_httpsclient==0.3.3',
++ 'pyasn1==0.1.9',
++ 'pyOpenSSL==16.0.0',
+ ])
+-
+ if sys.version_info.major == 2:
+ requirements.append('ipaddress')
+