summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2017-11-03 12:13:13 +0000
committerColin Watson <cjwatson@debian.org>2017-11-03 16:06:25 +0000
commitc5a506f9683bcc1d122b8d3b2999e82799a64faf (patch)
tree138fec5e41a3148e33717e13829d9b5341649f16 /debian
parentd8e82d564b638965b8e9c9d6fb23ae9496fdf355 (diff)
parent3d9eaeb5dacee168a93da090e2c0d46eedbe51a2 (diff)
New upstream release (0.0.4)
Diffstat (limited to 'debian')
-rw-r--r--debian/.git-dpm14
-rw-r--r--debian/changelog6
-rw-r--r--debian/control11
-rw-r--r--debian/patches/avoid-relative-imports.patch83
-rw-r--r--debian/patches/series1
5 files changed, 20 insertions, 95 deletions
diff --git a/debian/.git-dpm b/debian/.git-dpm
index f0f64ed..0e8f4a8 100644
--- a/debian/.git-dpm
+++ b/debian/.git-dpm
@@ -1,11 +1,11 @@
# see git-dpm(1) from git-dpm package
-1c453126cefd68073c089b7b334b8c793b38c152
-1c453126cefd68073c089b7b334b8c793b38c152
-79ff2842fa477ee0693ea167c0a74cd7cf080d27
-79ff2842fa477ee0693ea167c0a74cd7cf080d27
-py-macaroon-bakery_0.0.3.orig.tar.gz
-5a749b8bfce5cdc00084ced3301a356681c08647
-29083
+3d9eaeb5dacee168a93da090e2c0d46eedbe51a2
+3d9eaeb5dacee168a93da090e2c0d46eedbe51a2
+3d9eaeb5dacee168a93da090e2c0d46eedbe51a2
+3d9eaeb5dacee168a93da090e2c0d46eedbe51a2
+py-macaroon-bakery_0.0.4.orig.tar.gz
+0991cc6e4167b4b83740f03baa89123ff6d9a424
+69675
debianTag="debian/%e%v"
patchedTag="patched/%e%v"
upstreamTag="upstream/%e%u"
diff --git a/debian/changelog b/debian/changelog
index 3c79341..92170ca 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+py-macaroon-bakery (0.0.4-1) UNRELEASED; urgency=medium
+
+ * New upstream release.
+
+ -- Colin Watson <cjwatson@debian.org> Fri, 03 Nov 2017 12:13:49 +0000
+
py-macaroon-bakery (0.0.3-1) unstable; urgency=medium
* Initial release (closes: #866779).
diff --git a/debian/control b/debian/control
index a641fd2..d592607 100644
--- a/debian/control
+++ b/debian/control
@@ -8,12 +8,15 @@ Build-Depends: debhelper (>= 9~),
python3-all,
python3-httmock,
python3-mock,
- python3-nacl (>= 1.1.1),
+ python3-nacl (>= 1.1.2),
python3-nose,
- python3-pymacaroons (>= 0.10.0),
- python3-requests (>= 2.16.5),
+ python3-protobuf (>= 3.0.0),
+ python3-pymacaroons (>= 0.12.0),
+ python3-requests (>= 2.18.1),
+ python3-rfc3339 (>= 1.0),
python3-setuptools,
- python3-six (>= 1.10.0)
+ python3-six (>= 1.11.0),
+ python3-tz (>= 2017.2)
Standards-Version: 4.1.1
X-Python3-Version: >= 3.5
Vcs-Git: https://anonscm.debian.org/git/python-modules/packages/py-macaroon-bakery.git
diff --git a/debian/patches/avoid-relative-imports.patch b/debian/patches/avoid-relative-imports.patch
deleted file mode 100644
index 4b02a1e..0000000
--- a/debian/patches/avoid-relative-imports.patch
+++ /dev/null
@@ -1,83 +0,0 @@
-From 1c453126cefd68073c089b7b334b8c793b38c152 Mon Sep 17 00:00:00 2001
-From: Colin Watson <cjwatson@debian.org>
-Date: Thu, 2 Nov 2017 14:16:23 +0000
-Subject: Avoid relative imports to fix Python 3 tests
-
-This is fixed in a different way in 0.0.4.
-
-Forwarded: not-needed
-Last-Update: 2017-11-02
-
-Patch-Name: avoid-relative-imports.patch
----
- macaroonbakery/codec.py | 11 ++++++++---
- macaroonbakery/macaroon.py | 6 +++---
- 2 files changed, 11 insertions(+), 6 deletions(-)
-
-diff --git a/macaroonbakery/codec.py b/macaroonbakery/codec.py
-index 4015bbb..f5cc493 100644
---- a/macaroonbakery/codec.py
-+++ b/macaroonbakery/codec.py
-@@ -3,14 +3,13 @@
-
- import base64
- import json
--import namespace
-+from macaroonbakery import namespace
-
- from nacl.public import Box, PublicKey
- from nacl.encoding import Base64Encoder
- import six
-
--import bakery
--import macaroon
-+from macaroonbakery import bakery
-
- _PUBLIC_KEY_PREFIX_LEN = 4
- _KEY_LEN = 32
-@@ -178,6 +177,8 @@ def _decode_caveat_v1(key, caveat):
- @param caveat a base64 encoded JSON string.
- '''
-
-+ from macaroonbakery import macaroon
-+
- data = base64.b64decode(caveat).decode('utf-8')
- wrapper = json.loads(data)
- tp_public_key = PublicKey(base64.b64decode(wrapper['ThirdPartyPublicKey']))
-@@ -212,6 +213,8 @@ def _decode_caveat_v1(key, caveat):
- def _decode_caveat_v2_v3(version, key, caveat):
- '''Decodes a version 2 or version 3 caveat.
- '''
-+ from macaroonbakery import macaroon
-+
- if (len(caveat) < 1 + _PUBLIC_KEY_PREFIX_LEN +
- _KEY_LEN + Box.NONCE_SIZE + 16):
- raise ValueError('caveat id too short')
-@@ -243,6 +246,8 @@ def _decode_caveat_v2_v3(version, key, caveat):
-
-
- def _decode_secret_part_v2_v3(version, data):
-+ from macaroonbakery import macaroon
-+
- if len(data) < 1:
- raise ValueError('secret part too short')
- got_version = six.byte2int(data[:1])
-diff --git a/macaroonbakery/macaroon.py b/macaroonbakery/macaroon.py
-index b0a89bb..954161c 100644
---- a/macaroonbakery/macaroon.py
-+++ b/macaroonbakery/macaroon.py
-@@ -6,11 +6,11 @@ import copy
- import logging
- import os
-
--import bakery
--import codec
-+from macaroonbakery import bakery
-+from macaroonbakery import codec
- import pymacaroons
-
--import namespace
-+from macaroonbakery import namespace
-
- MACAROON_V1, MACAROON_V2 = 1, 2
-
diff --git a/debian/patches/series b/debian/patches/series
deleted file mode 100644
index 5b8cfe5..0000000
--- a/debian/patches/series
+++ /dev/null
@@ -1 +0,0 @@
-avoid-relative-imports.patch