summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2018-08-20 17:53:46 +0100
committerColin Watson <cjwatson@debian.org>2018-08-20 17:54:31 +0100
commitf3d0400ea57884c6bd7f1d66352d3e44ad20e286 (patch)
tree9e826ffbdb7cb51825b67bd35a33de79ccb97356 /setup.py
parentae33a39d857b367e216f1e80530c09087b108d16 (diff)
parent2105a515d749b74eef9a6bb6af008aa6a842e313 (diff)
Update upstream source from tag 'upstream/1.1.4'
Update to upstream version '1.1.4' with Debian dir 42ca954c317c7fd65bffdc0e0e6803556dccdf2f
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py7
1 files changed, 6 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 8beaad3..e0ed5d7 100755
--- a/setup.py
+++ b/setup.py
@@ -2,6 +2,7 @@
# Copyright 2017 Canonical Ltd.
# Licensed under the LGPLv3, see LICENCE file for details.
+import sys
import platform
from setuptools import (
@@ -12,7 +13,8 @@ from setuptools import (
PROJECT_NAME = 'macaroonbakery'
-VERSION = (1, 1, 3)
+# version 1.1.4
+VERSION = (1, 1, 4)
def get_version():
@@ -47,6 +49,9 @@ if len(distribution) == 3 and distribution[2] == 'trusty':
'ndg_httpsclient==0.3.3',
])
+if sys.version_info.major == 2:
+ requirements.append('ipaddress')
+
setup(
name=PROJECT_NAME,