summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2018-08-20 17:53:45 +0100
committerColin Watson <cjwatson@debian.org>2018-08-20 17:53:45 +0100
commit2105a515d749b74eef9a6bb6af008aa6a842e313 (patch)
treee1f3e72483f3d81c6f00a5c0abddb59a85ae47f2 /setup.py
parent4379a501141f75557e535f9c2ef3b58ef362259c (diff)
New upstream version 1.1.4
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py7
1 files changed, 6 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 8beaad3..e0ed5d7 100755
--- a/setup.py
+++ b/setup.py
@@ -2,6 +2,7 @@
# Copyright 2017 Canonical Ltd.
# Licensed under the LGPLv3, see LICENCE file for details.
+import sys
import platform
from setuptools import (
@@ -12,7 +13,8 @@ from setuptools import (
PROJECT_NAME = 'macaroonbakery'
-VERSION = (1, 1, 3)
+# version 1.1.4
+VERSION = (1, 1, 4)
def get_version():
@@ -47,6 +49,9 @@ if len(distribution) == 3 and distribution[2] == 'trusty':
'ndg_httpsclient==0.3.3',
])
+if sys.version_info.major == 2:
+ requirements.append('ipaddress')
+
setup(
name=PROJECT_NAME,