summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorFrancesco Banconi <francesco.banconi@canonical.com>2019-05-13 11:27:48 +0200
committerColin Watson <cjwatson@debian.org>2019-12-26 22:46:22 +0000
commit590e72a8af577c238da51d234a07cc199eff941a (patch)
tree5f0aeead37c9fcf415324d482f7f093a0b7c8421 /setup.py
parente1a7ba951eb867e0336c8cd090537d11ea5954ed (diff)
Avoid using deprecated platform.dist() in setup.py
Bug: https://github.com/go-macaroon-bakery/py-macaroon-bakery/issues/74 Origin: upstream, https://github.com/go-macaroon-bakery/py-macaroon-bakery/commit/3721180c4a3765e8807392fca2b7e7c2d7ffae45 Last-Update: 2019-12-26 Gbp-Pq: Name avoid-deprecated-platform-dist.patch
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py9
1 files changed, 3 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index f098e76..83aec8c 100755
--- a/setup.py
+++ b/setup.py
@@ -3,7 +3,6 @@
# Copyright 2017 Canonical Ltd.
# Licensed under the LGPLv3, see LICENCE file for details.
import sys
-import platform
from setuptools import (
find_packages,
@@ -39,16 +38,14 @@ test_requirements = [
'httmock==1.2.5',
]
-distribution = platform.dist()
-if len(distribution) == 3 and distribution[2] == 'trusty':
+if sys.version_info < (2, 7, 9):
# Injected into urllib3 to fix insecure Python 2.
requirements.extend([
'cryptography==1.3.2',
- 'pyOpenSSL==16.0.0',
- 'pyasn1==0.1.9',
'ndg_httpsclient==0.3.3',
+ 'pyasn1==0.1.9',
+ 'pyOpenSSL==16.0.0',
])
-
if sys.version_info.major == 2:
requirements.append('ipaddress')