summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--PKG-INFO2
-rw-r--r--macaroonbakery.egg-info/PKG-INFO2
-rw-r--r--macaroonbakery/bakery/_macaroon.py4
-rwxr-xr-xsetup.py4
4 files changed, 6 insertions, 6 deletions
diff --git a/PKG-INFO b/PKG-INFO
index 7e4987e..a3c2272 100644
--- a/PKG-INFO
+++ b/PKG-INFO
@@ -1,6 +1,6 @@
Metadata-Version: 1.1
Name: macaroonbakery
-Version: 1.3.0
+Version: 1.3.1
Summary: A Python library port for bakery, higher level operation to work with macaroons
Home-page: https://github.com/go-macaroon-bakery/py-macaroon-bakery
Author: Juju UI Team
diff --git a/macaroonbakery.egg-info/PKG-INFO b/macaroonbakery.egg-info/PKG-INFO
index 7e4987e..a3c2272 100644
--- a/macaroonbakery.egg-info/PKG-INFO
+++ b/macaroonbakery.egg-info/PKG-INFO
@@ -1,6 +1,6 @@
Metadata-Version: 1.1
Name: macaroonbakery
-Version: 1.3.0
+Version: 1.3.1
Summary: A Python library port for bakery, higher level operation to work with macaroons
Home-page: https://github.com/go-macaroon-bakery/py-macaroon-bakery
Author: Juju UI Team
diff --git a/macaroonbakery/bakery/_macaroon.py b/macaroonbakery/bakery/_macaroon.py
index 63091f6..1438ab1 100644
--- a/macaroonbakery/bakery/_macaroon.py
+++ b/macaroonbakery/bakery/_macaroon.py
@@ -115,11 +115,11 @@ class Macaroon(object):
'no private key to encrypt third party caveat')
local_info = _parse_local_location(cav.location)
if local_info is not None:
- info = local_info
- if cav.condition is not '':
+ if cav.condition:
raise ValueError(
'cannot specify caveat condition in '
'local third-party caveat')
+ info = local_info
cav = checkers.Caveat(location='local', condition='true')
else:
if loc is None:
diff --git a/setup.py b/setup.py
index d549aa5..4cf63f0 100755
--- a/setup.py
+++ b/setup.py
@@ -10,8 +10,8 @@ from setuptools import (
PROJECT_NAME = 'macaroonbakery'
-# version 1.3.0
-VERSION = (1, 3, 0)
+# version 1.3.1
+VERSION = (1, 3, 1)
def get_version():