summaryrefslogtreecommitdiff
path: root/debian/control
diff options
context:
space:
mode:
Diffstat (limited to 'debian/control')
-rw-r--r--debian/control44
1 files changed, 44 insertions, 0 deletions
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..445bb38
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,44 @@
+Source: py-macaroon-bakery
+Section: python
+Priority: optional
+Maintainer: Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
+Uploaders: Colin Watson <cjwatson@debian.org>
+Build-Depends: debhelper (>= 9~),
+ dh-python,
+ python3-all,
+ python3-httmock,
+ python3-mock,
+ python3-nacl (>= 1.1.2),
+ python3-nose,
+ python3-protobuf (>= 3.0.0),
+ python3-pymacaroons (>= 0.12.0),
+ python3-requests (>= 2.18.1),
+ python3-rfc3339 (>= 1.0),
+ python3-setuptools,
+ python3-six (>= 1.11.0),
+Standards-Version: 4.1.1
+X-Python3-Version: >= 3.5
+Vcs-Git: https://salsa.debian.org/python-team/modules/py-macaroon-bakery.git
+Vcs-Browser: https://salsa.debian.org/python-team/modules/py-macaroon-bakery
+Homepage: https://github.com/go-macaroon-bakery/py-macaroon-bakery
+Rules-Requires-Root: no
+
+Package: python3-macaroonbakery
+Architecture: all
+Multi-Arch: foreign
+Depends: ${misc:Depends},
+ ${python3:Depends}
+Description: Higher-level macaroon operations for Python 3
+ Macaroons, like cookies, are a form of bearer credential. Unlike opaque
+ tokens, macaroons embed caveats that define specific authorization
+ requirements for the target service, the service that issued the root
+ macaroon and which is capable of verifying the integrity of macaroons it
+ receives.
+ .
+ Macaroons allow for delegation and attenuation of authorization. They are
+ simple and fast to verify, and decouple authorization policy from the
+ enforcement of that policy.
+ .
+ The macaroonbakery library builds on pymacaroons to allow working with
+ macaroons at a higher level, such as by automatically gathering discharge
+ macaroons for third-party caveats from their corresponding services.