summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/isolate-from-proxy.patch43
-rw-r--r--debian/patches/lower-protobuf-requests-deps.patch32
-rw-r--r--debian/patches/series2
3 files changed, 44 insertions, 33 deletions
diff --git a/debian/patches/isolate-from-proxy.patch b/debian/patches/isolate-from-proxy.patch
new file mode 100644
index 0000000..ee5d08a
--- /dev/null
+++ b/debian/patches/isolate-from-proxy.patch
@@ -0,0 +1,43 @@
+From 8051fc0e07186078ae5419ac9de246cf6e57359a Mon Sep 17 00:00:00 2001
+From: Colin Watson <cjwatson@debian.org>
+Date: Mon, 6 Nov 2017 10:27:10 +0000
+Subject: Isolate client tests from any HTTP proxy
+
+Debian's Python packaging tools set http_proxy to a non-existent proxy
+to help flush out packages that try to talk to the network during build,
+but these tests could previously fail in more normal development
+environments too.
+
+Forwarded: https://github.com/go-macaroon-bakery/py-macaroon-bakery/pull/28
+Last-Update: 2017-11-06
+
+Patch-Name: isolate-from-proxy.patch
+---
+ macaroonbakery/tests/test_client.py | 7 +++++++
+ 1 file changed, 7 insertions(+)
+
+diff --git a/macaroonbakery/tests/test_client.py b/macaroonbakery/tests/test_client.py
+index e1a4009..8263f54 100644
+--- a/macaroonbakery/tests/test_client.py
++++ b/macaroonbakery/tests/test_client.py
+@@ -3,6 +3,7 @@
+ import base64
+ import datetime
+ import json
++import os
+ from unittest import TestCase
+ try:
+ from BaseHTTPServer import HTTPServer, BaseHTTPRequestHandler
+@@ -26,6 +27,12 @@ TEST_OP = bakery.Op(entity='test', action='test')
+
+
+ class TestClient(TestCase):
++ def setUp(self):
++ super(TestClient, self).setUp()
++ # http_proxy would cause requests to talk to the proxy, which is
++ # unlikely to know how to talk to the test server.
++ os.environ.pop('http_proxy', None)
++
+ def test_single_service_first_party(self):
+ b = new_bakery('loc', None, None)
+
diff --git a/debian/patches/lower-protobuf-requests-deps.patch b/debian/patches/lower-protobuf-requests-deps.patch
deleted file mode 100644
index 112c9ba..0000000
--- a/debian/patches/lower-protobuf-requests-deps.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 075e9d186663b19cc3d3a892377e28fcfd7993a7 Mon Sep 17 00:00:00 2001
-From: Andrea Azzarone <andrea.azzarone@canonical.com>
-Date: Fri, 3 Nov 2017 15:00:01 +0000
-Subject: Lowering the protobuf and requests deps.
-
-Origin: other, https://github.com/go-macaroon-bakery/py-macaroon-bakery/pull/26
-Forwarded: https://github.com/go-macaroon-bakery/py-macaroon-bakery/pull/26
-Patch-Name: lower-protobuf-requests-deps.patch
-
-Last-Update: 2017-11-03
----
- setup.py | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/setup.py b/setup.py
-index 7fbc6d3..54000e9 100755
---- a/setup.py
-+++ b/setup.py
-@@ -24,11 +24,11 @@ with open('README.rst') as readme_file:
- readme = readme_file.read()
-
- requirements = [
-- 'requests>=2.18.4,<3.0',
-+ 'requests>=2.18.1,<3.0',
- 'PyNaCl>=1.1.2,<2.0',
- 'pymacaroons>=0.12.0,<1.0',
- 'six>=1.11.0,<2.0',
-- 'protobuf>=3.4.0,<4.0',
-+ 'protobuf>=3.0.0,<4.0',
- 'pyRFC3339>=1.0,<2.0',
- 'pytz>=2017.2,<2018.0'
- ]
diff --git a/debian/patches/series b/debian/patches/series
index f688483..781b9ec 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1 @@
-lower-protobuf-requests-deps.patch
+isolate-from-proxy.patch