summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py22
1 files changed, 16 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 989b8cc..7fbc6d3 100755
--- a/setup.py
+++ b/setup.py
@@ -11,16 +11,26 @@ from setuptools import (
PROJECT_NAME = 'macaroonbakery'
-project = __import__(PROJECT_NAME)
+
+VERSION = (0, 0, 4)
+
+
+def get_version():
+ '''Return the macaroon bakery version as a string.'''
+ return '.'.join(map(str, VERSION))
+
with open('README.rst') as readme_file:
readme = readme_file.read()
requirements = [
- 'requests>=2.16.5',
- 'PyNaCl>=1.1.2',
- 'pymacaroons>=0.10.0',
- 'six>=1.10.0',
+ 'requests>=2.18.4,<3.0',
+ 'PyNaCl>=1.1.2,<2.0',
+ 'pymacaroons>=0.12.0,<1.0',
+ 'six>=1.11.0,<2.0',
+ 'protobuf>=3.4.0,<4.0',
+ 'pyRFC3339>=1.0,<2.0',
+ 'pytz>=2017.2,<2018.0'
]
test_requirements = [
@@ -41,7 +51,7 @@ if len(distribution) == 3 and distribution[2] == 'trusty':
setup(
name=PROJECT_NAME,
- version=project.get_version(),
+ version=get_version(),
description='A Python library port for bakery, higher level operation '
'to work with macaroons',
long_description=readme,