summaryrefslogtreecommitdiff
path: root/debian/patches/avoid-deprecated-platform-dist.patch
blob: 0bb3bd2e1ebb7d6e96acfba923cfca49b2f8b4a9 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
From: Francesco Banconi <francesco.banconi@canonical.com>
Date: Mon, 13 May 2019 11:27:48 +0200
Subject: Avoid using deprecated platform.dist() in setup.py

Bug: https://github.com/go-macaroon-bakery/py-macaroon-bakery/issues/74
Origin: upstream, https://github.com/go-macaroon-bakery/py-macaroon-bakery/commit/3721180c4a3765e8807392fca2b7e7c2d7ffae45
Last-Update: 2019-12-26
---
 setup.py | 9 +++------
 1 file changed, 3 insertions(+), 6 deletions(-)

diff --git a/setup.py b/setup.py
index f098e76..83aec8c 100755
--- a/setup.py
+++ b/setup.py
@@ -3,7 +3,6 @@
 # Copyright 2017 Canonical Ltd.
 # Licensed under the LGPLv3, see LICENCE file for details.
 import sys
-import platform
 
 from setuptools import (
     find_packages,
@@ -39,16 +38,14 @@ test_requirements = [
     'httmock==1.2.5',
 ]
 
-distribution = platform.dist()
-if len(distribution) == 3 and distribution[2] == 'trusty':
+if sys.version_info < (2, 7, 9):
     # Injected into urllib3 to fix insecure Python 2.
     requirements.extend([
         'cryptography==1.3.2',
-        'pyOpenSSL==16.0.0',
-        'pyasn1==0.1.9',
         'ndg_httpsclient==0.3.3',
+        'pyasn1==0.1.9',
+        'pyOpenSSL==16.0.0',
     ])
-
 if sys.version_info.major == 2:
     requirements.append('ipaddress')