summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@debian.org>2018-04-28 13:11:07 +0200
committerPicca Frédéric-Emmanuel <picca@debian.org>2018-04-28 13:11:19 +0200
commitc5a1783f1abac7e06839f77c5920131c495ef316 (patch)
tree53fbf159db9af35ce5245527cccc8a86c2f33b6d
parent1fd1ff942cd7d531f6bce05e1edc556a1e0b1ca3 (diff)
generate the python dependencies via setuptools
-rw-r--r--debian/changelog1
-rw-r--r--debian/control23
-rw-r--r--debian/patches/0001-Added-install_requires-for-Debian.patch28
-rw-r--r--debian/patches/series1
-rw-r--r--debian/py3dist-overrides1
-rw-r--r--debian/pydist-overrides1
6 files changed, 40 insertions, 15 deletions
diff --git a/debian/changelog b/debian/changelog
index baa0a7b..f2dd963 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -20,6 +20,7 @@ pymca (5.3.1+dfsg-1) UNRELEASED; urgency=medium
+ python[3]-qtconsole,
* d/patches
- 0001-xlocale.h-not-available-under-glibc-2.26.patch (obsolete)
+ + 0001-Added-install_requires-for-Debian.patch (Added)
-- Picca Frédéric-Emmanuel <picca@debian.org> Sat, 28 Apr 2018 09:49:21 +0200
diff --git a/debian/control b/debian/control
index d3769d7..843fb6c 100644
--- a/debian/control
+++ b/debian/control
@@ -87,11 +87,6 @@ Package: python-pymca5
Architecture: any
Section: python
Depends: pymca-data (= ${source:Version}),
- python-fisx (>= 1.1.4-1~),
- python-matplotlib,
- python-opengl,
- python-qt4 | python-pyside | python-pyqt5,
- python-qt4-gl | python-pyside | python-pyqt5.qtopengl,
${misc:Depends},
${python:Depends},
${shlibs:Depends}
@@ -120,11 +115,13 @@ Package: python-pymca5-dbg
Architecture: any
Section: debug
Depends: python-fisx-dbg (>= 1.1.4-1~),
+ python-h5py-dbg,
python-matplotlib-dbg,
+ python-numpy-dbg,
python-opengl,
python-pymca5 (= ${binary:Version}),
- python-qt4-dbg | python-pyqt5-dbg,
- python-qt4-gl-dbg | python-pyqt5.qtopengl-dbg,
+ python-pyqt5-dbg,
+ python-pyqt5.qtopengl-dbg,
${misc:Depends},
${python:Depends},
${shlibs:Depends}
@@ -153,11 +150,6 @@ Package: python3-pymca5
Architecture: any
Section: python
Depends: pymca-data (= ${source:Version}),
- python3-fisx (>= 1.1.4-1~),
- python3-matplotlib,
- python3-opengl,
- python3-pyqt4 | python3-pyside | python3-pyqt5,
- python3-pyqt4.qtopengl | python3-pyside | python3-pyqt5.qtopengl,
${misc:Depends},
${python3:Depends},
${shlibs:Depends}
@@ -186,11 +178,12 @@ Package: python3-pymca5-dbg
Architecture: any
Section: debug
Depends: python3-fisx-dbg (>= 1.1.4-1~),
+ python3-h5py-dbg,
python3-matplotlib-dbg,
- python3-opengl,
+ python3-numpy-dbg,
python3-pymca5 (= ${binary:Version}),
- python3-pyqt4-dbg | python3-pyqt5-dbg,
- python3-pyqt4.qtopengl-dbg | python3-pyqt5.qtopengl-dbg,
+ python3-pyqt5-dbg,
+ python3-pyqt5.qtopengl-dbg,
${misc:Depends},
${python3:Depends},
${shlibs:Depends}
diff --git a/debian/patches/0001-Added-install_requires-for-Debian.patch b/debian/patches/0001-Added-install_requires-for-Debian.patch
new file mode 100644
index 0000000..0fa05e6
--- /dev/null
+++ b/debian/patches/0001-Added-install_requires-for-Debian.patch
@@ -0,0 +1,28 @@
+From: =?utf-8?q?Picca_Fr=C3=A9d=C3=A9ric-Emmanuel?= <picca@debian.org>
+Date: Sat, 28 Apr 2018 13:01:35 +0200
+Subject: Added install_requires for Debian
+
+---
+ setup.py | 9 ++++++++-
+ 1 file changed, 8 insertions(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 593f50c..9803bc7 100644
+--- a/setup.py
++++ b/setup.py
+@@ -827,7 +827,14 @@ classifiers = ["Development Status :: 5 - Production/Stable",
+ "Topic :: Scientific/Engineering :: Visualization",
+ ]
+
+-install_requires = ["numpy", "matplotlib", "fisx>=1.1.4"]
++install_requires = ["numpy", "matplotlib", "fisx>=1.1.4",
++ # Added by Debian
++ "PyOpenGL",
++ "h5py",
++ "matplotlib>1.0",
++ "qtconsole",
++ "PyQt5",
++ "silx>=0.7"]
+ setup_requires = ["numpy"]
+
+ distrib = setup(name="PyMca5",
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..a19efbc
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+0001-Added-install_requires-for-Debian.patch
diff --git a/debian/py3dist-overrides b/debian/py3dist-overrides
new file mode 100644
index 0000000..b4a4eed
--- /dev/null
+++ b/debian/py3dist-overrides
@@ -0,0 +1 @@
+pyqt5 python3-pyqt5,python3-pyqt5.qtopengl \ No newline at end of file
diff --git a/debian/pydist-overrides b/debian/pydist-overrides
new file mode 100644
index 0000000..8312180
--- /dev/null
+++ b/debian/pydist-overrides
@@ -0,0 +1 @@
+pyqt5 python-pyqt5,python-pyqt5.qtopengl