summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@debian.org>2021-09-05 11:07:10 +0200
committerPicca Frédéric-Emmanuel <picca@debian.org>2021-09-05 11:07:10 +0200
commiteda02ca64d46d0852d45002c21742a2e9dc26bda (patch)
tree10dfff72481e049d1a406a3792a0a45a658d2028
parent02bcfc16d296d63cad323e819afbf5f7172e5b46 (diff)
Used dh-sequence-X
-rw-r--r--debian/changelog9
-rw-r--r--debian/control3
-rwxr-xr-xdebian/rules26
3 files changed, 23 insertions, 15 deletions
diff --git a/debian/changelog b/debian/changelog
index 13aa4c8..342b11b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,8 +5,15 @@ pymca (5.6.5+dfsg-1) UNRELEASED; urgency=medium
* Update standards version to 4.5.1, no changes needed.
* Apply multi-arch hints.
+ python3-pymca5-dbg: Add Multi-Arch: same.
+ * d/p/0002-switch-to-qhull_r.patch: Added
+ * Bug fix: "depends on deprecated qhull library", thanks to Timo Röhling
+ (Closes: #990396).
+ * d/control: Used dh-sequence-[numpy3,python3,sphinxdoc]
+ * d/rules:
+ + Simplifier thanks to dh-sequence-X
+ + Used execute_[after|before]
- -- Picca Frédéric-Emmanuel <picca@debian.org> Mon, 30 Aug 2021 16:32:04 +0200
+ -- Picca Frédéric-Emmanuel <picca@debian.org> Sun, 05 Sep 2021 10:39:56 +0200
pymca (5.6.3+dfsg-1) unstable; urgency=medium
diff --git a/debian/control b/debian/control
index 27a429a..8bbf0eb 100644
--- a/debian/control
+++ b/debian/control
@@ -8,6 +8,9 @@ Build-Depends: cython3,
dbus,
debhelper-compat (= 13),
dh-python,
+ dh-sequence-numpy3,
+ dh-sequence-python3,
+ dh-sequence-sphinxdoc <!nodoc>,
libglu1-mesa-dev,
libqhull-dev,
locales-all <!nocheck>,
diff --git a/debian/rules b/debian/rules
index 06c7749..95543b5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -40,10 +40,9 @@ export WITH_OPENGL_TEST=False
endif
%:
- dh $@ --with python3,sphinxdoc --buildsystem=pybuild
+ dh $@ --buildsystem=pybuild
-override_dh_clean:
- dh_clean
+execute_after_dh_clean:
# remove the cython generated file to force rebuild
rm -f $(patsubst %.pyx,%.cpp,${ALL_PYX})
rm -f $(patsubst %.pyx,%.c,${ALL_PYX})
@@ -54,12 +53,15 @@ override_dh_clean:
# remove a.out generated by configuration
rm -rf a.out
+execute_after_dh_auto_build:
+ifeq (,$(findstring nodoc, $(DEB_BUILD_OPTIONS)))
+ pybuild --build -s custom -p $(PY3VER) --build-args="cd doc && PYTHONPATH={build_dir} PYMCA_DATA_DIR=$(PYMCA_DATA_DIR_TEST) PYMCA_DOC_DIR=$(PYMCA_DOC_DIR_TEST) http_proxy='127.0.0.1:9' {interpreter} -m sphinx -N -bhtml source build/html"
+endif
+
override_dh_installchangelogs:
dh_installchangelogs changelog.txt
-override_dh_install:
- dh_install -O--buildsystem=pybuild
-
+execute_after_dh_install:
# pymca
python3 setup.py install_scripts -d debian/pymca/usr/bin
python3 setup.py install_man -d debian/pymca/usr/share/man
@@ -77,16 +79,12 @@ override_dh_install:
rm -f debian/pymca-data/usr/share/pymca/LICENSE.MIT
rm -rf debian/pymca-data/usr/share/pymca/doc/HTML/PyMCA_files/
- dh_numpy3
+execute_after_dh_installdocs:
+ifeq (,$(findstring nodoc, $(DEB_BUILD_OPTIONS)))
+ dh_installdocs -p pymca-doc "doc/build/html"
+endif
override_dh_auto_test:
ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
pybuild --test -s custom -p $(PY3VER) --test-args="cd {build_dir} && PYMCA_DATA_DIR=$(PYMCA_DATA_DIR_TEST) PYMCA_DOC_DIR=$(PYMCA_DOC_DIR_TEST) xvfb-run -a --server-args=\"-screen 0 1024x768x24\" {interpreter} PyMca5/tests/TestAll.py"
endif
-
-override_dh_sphinxdoc:
-ifeq (,$(findstring nodoc, $(DEB_BUILD_OPTIONS)))
- pybuild --build -s custom -p $(PY3VER) --build-args="cd doc && PYTHONPATH={build_dir} PYMCA_DATA_DIR=$(PYMCA_DATA_DIR_TEST) PYMCA_DOC_DIR=$(PYMCA_DOC_DIR_TEST) http_proxy='127.0.0.1:9' {interpreter} -m sphinx -N -bhtml source build/html"
- dh_installdocs "doc/build/html" -p pymca-doc
- dh_sphinxdoc -O--buildsystem=pybuild
-endif