summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@debian.org>2019-07-19 12:02:10 +0200
committerPicca Frédéric-Emmanuel <picca@debian.org>2019-07-19 12:02:10 +0200
commit1611205a4fdb01fa72cb952ef6497b8117fd702f (patch)
tree2103c4f4b7a3b1569739e686ae98cf89c0b178b9
parent8d0b42fc05f9ce82d31f700d0dd253a10f54f1b9 (diff)
run the tets only for the current python3 version
-rwxr-xr-xdebian/rules8
1 files changed, 4 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 0deb3ac..0d5c7a0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -14,10 +14,11 @@ export PYMCA_DATA_DIR_TEST=$(CURDIR)/PyMca5/PyMcaData/
export PYMCA_DOC_DIR_TEST=$(PYMCA_DATA_DIR_TEST)
export PYBUILD_NAME=pymca5
-export PYBUILD_DISABLE_python2=test
-export PYBUILD_DISABLE_python2-dbg=test
export PYBUILD_AFTER_INSTALL=rm -rf {destdir}/usr/bin/ {destdir}/usr/share/man {destdir}$(PYMCA_DATA_DIR)
+# get the default python3 interpreter version
+PY3VER := $(shell py3versions -dv)
+
# Make does not offer a recursive wildcard function, so here's one:
rwildcard=$(wildcard $1$2) $(foreach d,$(wildcard $1*),$(call rwildcard,$d/,$2))
@@ -65,8 +66,7 @@ override_dh_install:
dh_numpy3
override_dh_auto_test:
- PYBUILD_SYSTEM=custom \
- PYBUILD_TEST_ARGS="cd {build_dir} && PYMCA_DATA_DIR=$(PYMCA_DATA_DIR_TEST) PYMCA_DOC_DIR=$(PYMCA_DOC_DIR_TEST) xvfb-run -a --server-args=\"-screen 0 1024x768x24\" {interpreter} PyMca5/tests/TestAll.py" dh_auto_test
+ dh_auto_test -- -s custom -p $(PY3VER) --test-args="cd {build_dir} && PYMCA_DATA_DIR=$(PYMCA_DATA_DIR_TEST) PYMCA_DOC_DIR=$(PYMCA_DOC_DIR_TEST) xvfb-run -a --server-args=\"-screen 0 1024x768x24\" {interpreter} PyMca5/tests/TestAll.py"
override_dh_sphinxdoc:
ifeq (,$(findstring nodocs, $(DEB_BUILD_OPTIONS)))