summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNilesh Patra <nilesh@debian.org>2021-11-03 07:06:53 +0000
committerNilesh Patra <nilesh@debian.org>2021-11-03 12:38:48 +0530
commit0a49bbc1c524bd6b79a895847ad477ce9b85e6b6 (patch)
tree103d04e87b4ca740c8e805a78092e0f1ebd60faf
parent1f8f65fed336d4ffe9734e272c8d41bc732fd537 (diff)
[skip ci] Add patch to fix tests
-rw-r--r--debian/changelog3
-rw-r--r--debian/patches/fix_dtype.patch15
-rw-r--r--debian/patches/series1
3 files changed, 18 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 87b5e78..4b98ee8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,8 +6,9 @@ pyranges (0.0.111+ds-1) UNRELEASED; urgency=medium
[ Nilesh Patra ]
* New upstream version 0.0.111+ds
* Run cme
+ * Add patch to fix tests
- -- Nilesh Patra <nilesh@debian.org> Tue, 02 Nov 2021 23:28:55 +0530
+ -- Nilesh Patra <nilesh@debian.org> Wed, 03 Nov 2021 07:06:31 +0000
pyranges (0.0.85+ds-1) unstable; urgency=medium
diff --git a/debian/patches/fix_dtype.patch b/debian/patches/fix_dtype.patch
new file mode 100644
index 0000000..1e61381
--- /dev/null
+++ b/debian/patches/fix_dtype.patch
@@ -0,0 +1,15 @@
+Description: Explicitly case variable to category dtype
+Author: Nilesh Patra <nilesh@debian.org>
+Last-Update: 2021-11-03
+--- a/pyranges/methods/concat.py
++++ b/pyranges/methods/concat.py
+@@ -43,7 +43,8 @@
+ if any(strand_info) and not all(strand_info):
+ new_res = {}
+ for k, v in res.items():
+- v.loc[:, "Strand"] = v.Strand.cat.add_categories(["."])
++ type_v = v.Strand.astype('category')
++ v.loc[:, "Strand"] = type_v.cat.add_categories(["."])
+ new_res[k] = v.assign(Strand=v.Strand.fillna("."))
+ res = pr.PyRanges(new_res)
+ res.Strand = res.Strand
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..fb85c46
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+fix_dtype.patch