summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog12
-rw-r--r--debian/clean4
-rw-r--r--debian/control3
-rw-r--r--debian/patches/healthcheck-all.patch27
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules6
-rw-r--r--tests/test_unary.py2
7 files changed, 49 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index 81007e2..9ba27bb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,15 @@
+pyranges (0.0.111+ds-5) unstable; urgency=medium
+
+ * healthcheck-all.patch: new: fix test failure.
+ The test failure seems to be caused by a call to an obsoleted method
+ in a decorator describing the properties of the affected test.
+ (Closes: #1042046)
+ * d/control: add myself to uploaders.
+ * d/rules: use execute_after_dh_* targets in place of overrides.
+ * d/clean: remove remnants of *.bam* test data.
+
+ -- Étienne Mollier <emollier@debian.org> Wed, 23 Aug 2023 19:54:31 +0200
+
pyranges (0.0.111+ds-4) unstable; urgency=medium
* Team upload.
diff --git a/debian/clean b/debian/clean
new file mode 100644
index 0000000..8efb1c7
--- /dev/null
+++ b/debian/clean
@@ -0,0 +1,4 @@
+pyranges/example_data/control.bam
+pyranges/example_data/control.bam.bai
+tests/test_data/test_sorted.bam
+tests/test_data/test_sorted.bam.bai
diff --git a/debian/control b/debian/control
index d5b99ea..92193c1 100644
--- a/debian/control
+++ b/debian/control
@@ -1,6 +1,7 @@
Source: pyranges
Maintainer: Debian Med Packaging Team <debian-med-packaging@lists.alioth.debian.org>
-Uploaders: Steffen Moeller <moeller@debian.org>
+Uploaders: Steffen Moeller <moeller@debian.org>,
+ Étienne Mollier <emollier@debian.org>
Section: python
Testsuite: autopkgtest-pkg-python
Priority: optional
diff --git a/debian/patches/healthcheck-all.patch b/debian/patches/healthcheck-all.patch
new file mode 100644
index 0000000..b49296e
--- /dev/null
+++ b/debian/patches/healthcheck-all.patch
@@ -0,0 +1,27 @@
+Description: fix deprecated HealthCheck.all() decorator parameter.
+ The HealthCheck.all() method has been deprecated in favor of specifying in a
+ list which checks to ignore in a subsequent test function. The error message
+ suggests use of HealthCheck.return_value. Other options are documented on
+ Python hypothesis module documentation[1]. It is worth noting the attribute
+ return_value itself is marked as deprecated, so we might as well just buy us
+ some time until a possibly more appropriate fix.
+ .
+ [1]: https://hypothesis.readthedocs.io/en/latest/settings.html#health-checks
+
+Author: Étienne Mollier <emollier@debian.org>
+Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1042046
+Forwarded: no
+Last-Update: 2023-08-23
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- pyranges.orig/tests/test_unary.py
++++ pyranges/tests/test_unary.py
+@@ -289,7 +289,7 @@
+ @settings(
+ max_examples=max_examples,
+ deadline=deadline,
+- suppress_health_check=HealthCheck.all())
++ suppress_health_check=[HealthCheck.return_value])
+ @given(selector=selector()) # pylint: disable=no-value-for-parameter
+ def test_getitem(selector):
+
diff --git a/debian/patches/series b/debian/patches/series
index b9467fc..0a042cc 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,4 @@
fix_dtype.patch
reorder.patch
numpy_1.24.patch
+healthcheck-all.patch
diff --git a/debian/rules b/debian/rules
index 50fbe09..e3b8a81 100755
--- a/debian/rules
+++ b/debian/rules
@@ -13,16 +13,14 @@ export PYBUILD_TEST_ARGS=-n $(shell nproc)
%:
dh $@ --with python3 --buildsystem=pybuild
-override_dh_auto_build:
- dh_auto_build
+execute_after_dh_auto_build:
echo 'Generating corresponding files ...'
cat debian/missing-sources/test_sorted.sam| samtools view -Sb - > tests/test_data/test_sorted.bam
cat debian/missing-sources/control.sam| samtools view -Sb - > pyranges/example_data/control.bam
samtools index tests/test_data/test_sorted.bam tests/test_data/test_sorted.bam.bai
samtools index pyranges/example_data/control.bam pyranges/example_data/control.bam.bai
-override_dh_install:
- dh_install
+execute_after_dh_install:
find debian/ -name *.bam* | xargs rm -rf
find debian/ -name 'hi' | xargs rm -rf
find debian/ -name '.hypothesis' | xargs rm -rf
diff --git a/tests/test_unary.py b/tests/test_unary.py
index 06548c2..8d922cd 100644
--- a/tests/test_unary.py
+++ b/tests/test_unary.py
@@ -289,7 +289,7 @@ chipseq = pr.data.chipseq()
@settings(
max_examples=max_examples,
deadline=deadline,
- suppress_health_check=HealthCheck.all())
+ suppress_health_check=[HealthCheck.return_value])
@given(selector=selector()) # pylint: disable=no-value-for-parameter
def test_getitem(selector):