summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 2 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 50fbe09..e3b8a81 100755
--- a/debian/rules
+++ b/debian/rules
@@ -13,16 +13,14 @@ export PYBUILD_TEST_ARGS=-n $(shell nproc)
%:
dh $@ --with python3 --buildsystem=pybuild
-override_dh_auto_build:
- dh_auto_build
+execute_after_dh_auto_build:
echo 'Generating corresponding files ...'
cat debian/missing-sources/test_sorted.sam| samtools view -Sb - > tests/test_data/test_sorted.bam
cat debian/missing-sources/control.sam| samtools view -Sb - > pyranges/example_data/control.bam
samtools index tests/test_data/test_sorted.bam tests/test_data/test_sorted.bam.bai
samtools index pyranges/example_data/control.bam pyranges/example_data/control.bam.bai
-override_dh_install:
- dh_install
+execute_after_dh_install:
find debian/ -name *.bam* | xargs rm -rf
find debian/ -name 'hi' | xargs rm -rf
find debian/ -name '.hypothesis' | xargs rm -rf