summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xdebian/rules1
-rw-r--r--debian/tests/control9
-rwxr-xr-xdebian/tests/upstream-tests8
4 files changed, 25 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 1e434f8..118ecb3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+python-can (4.0.0~github-2) unstable; urgency=medium
+
+ * Disable Multicast/IP tests during build (not runnable on buildd)
+ * Add autopkgtest (that includes the Multicast/IP tests)
+
+ -- IOhannes m zmölnig (Debian/GNU) <umlaeute@debian.org> Thu, 14 Jul 2022 12:53:21 +0200
+
python-can (4.0.0~github-1) unstable; urgency=medium
* New upstream version 4.0.0~github
diff --git a/debian/rules b/debian/rules
index bce28b8..209faf0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,6 +2,7 @@
export PYBUILD_NAME=can
export PYBUILD_BEFORE_TEST=cp -r {dir}/test {build_dir}
+export PYBUILD_TEST_ARGS=-k 'not BasicTestUdpMulticastBusIP'
include /usr/share/dpkg/default.mk
export DEB_VERSION_UPSTREAM
diff --git a/debian/tests/control b/debian/tests/control
new file mode 100644
index 0000000..b1a47b8
--- /dev/null
+++ b/debian/tests/control
@@ -0,0 +1,9 @@
+Tests: upstream-tests
+Depends:
+ python3-can,
+ python3-hypothesis,
+ python3-mock,
+ python3-parameterized,
+ python3-pytest,
+ python3-pytest-timeout,
+Restrictions: allow-stderr
diff --git a/debian/tests/upstream-tests b/debian/tests/upstream-tests
new file mode 100755
index 0000000..78b6ce4
--- /dev/null
+++ b/debian/tests/upstream-tests
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+set -e
+
+mv can can_
+
+cd test
+pytest .