summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTianon Gravi <tianon@debian.org>2015-11-08 10:36:49 -0800
committerAndrej Shadura <andrewsh@debian.org>2021-12-31 21:31:27 +0100
commitc7c8d718fea0d9c46a8f7cec3eb9f74072dc922f (patch)
tree473c5f1f8327e67c1ab5695ea293c09176d7e012
parentdbf47ac9396919734cc818d8d56be93123c52e53 (diff)
Unpin dependencies so newer versions satisfy them appropriatelyarchive/debian/5.0.3-1_bpo11+1
Forwarded: https://github.com/dotcloud/docker-py/issues/101 (upstream has no interest) Patch-Name: requirements.patch Gbp-Pq: Name requirements.patch
-rw-r--r--requirements.txt33
-rw-r--r--setup.py2
-rw-r--r--test-requirements.txt14
3 files changed, 24 insertions, 25 deletions
diff --git a/requirements.txt b/requirements.txt
index 26cbc6f..34a3083 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -1,17 +1,16 @@
-appdirs==1.4.3
-asn1crypto==0.22.0
-backports.ssl-match-hostname==3.5.0.1
-cffi==1.14.4
-cryptography==3.4.7
-enum34==1.1.6
-idna==2.5
-ipaddress==1.0.18
-packaging==16.8
-paramiko==2.4.2
-pycparser==2.17
-pyOpenSSL==18.0.0
-pyparsing==2.2.0
-pywin32==301; sys_platform == 'win32'
-requests==2.26.0
-urllib3==1.26.5
-websocket-client==0.56.0
+appdirs>=1.4.3
+asn1crypto>=0.22.0
+backports.ssl-match-hostname>=3.5.0.1
+cffi>=1.14.4
+cryptography>=3.2
+enum34>=1.1.6
+idna>=2.5
+ipaddress>=1.0.18
+packaging>=16.8
+paramiko>=2.4.2
+pycparser>=2.17
+pyOpenSSL>=18.0.0
+pyparsing>=2.2.0
+requests>=2.25.0
+urllib3>=1.26.5
+websocket-client>=0.56.0
diff --git a/setup.py b/setup.py
index a966fea..5b9945d 100644
--- a/setup.py
+++ b/setup.py
@@ -26,7 +26,7 @@ extras_require = {
# https://github.com/pypa/pip/issues/4391). Once that's fixed, instead of
# installing the extra dependencies, install the following instead:
# 'requests[security] >= 2.5.2, != 2.11.0, != 2.12.2'
- 'tls': ['pyOpenSSL>=17.5.0', 'cryptography>=3.4.7', 'idna>=2.0.0'],
+ 'tls': ['pyOpenSSL>=17.5.0', 'cryptography>=3.2', 'idna>=2.0.0'],
# Only required when connecting using the ssh:// protocol
'ssh': ['paramiko>=2.4.2'],
diff --git a/test-requirements.txt b/test-requirements.txt
index 40161bb..585e3fd 100644
--- a/test-requirements.txt
+++ b/test-requirements.txt
@@ -1,7 +1,7 @@
-setuptools==54.1.1
-coverage==4.5.2
-flake8==3.6.0
-mock==1.0.1
-pytest==4.3.1
-pytest-cov==2.6.1
-pytest-timeout==1.3.3
+setuptools>=54.1.1
+coverage>=4.5.2
+flake8>=3.6.0
+mock>=1.0.1
+pytest>=4.3.1
+pytest-cov>=2.6.1
+pytest-timeout>=1.3.3