summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Pleau <jason@jpleau.ca>2018-04-10 22:08:49 -0400
committerJason Pleau <jason@jpleau.ca>2018-04-10 22:08:49 -0400
commitca8b8e508ec6afd5be50e20ed85a98d87264aacc (patch)
tree81586dd7b49e9e6f0e0082aef1f27789725aa66b
parentc48a8f0b4fd119ed26cbcccd3044b3f12b435f70 (diff)
parentfd17cbb77d4ab29923c5c53523615f6630f75753 (diff)
Merge branch 'update_3.2.1'
-rw-r--r--debian/changelog9
-rw-r--r--debian/control8
-rw-r--r--debian/patches/requirements.patch30
3 files changed, 25 insertions, 22 deletions
diff --git a/debian/changelog b/debian/changelog
index 4f973e5..d6674ed 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,13 @@
-python-docker (2.5.1-2) UNRELEASED; urgency=medium
+python-docker (3.2.1-1) UNRELEASED; urgency=medium
+ * New upstrema release
* Update Vcs-* fields to point to salsa.d.o
+ * Refresh requirements.patch
+ * Update Standards-Version to 4.1.3, no changes needed
+ * Add Breaks for docker-compose << 1.21
- -- Jason Pleau <jason@jpleau.ca> Tue, 27 Feb 2018 22:17:28 -0500
+
+ -- Jason Pleau <jason@jpleau.ca> Fri, 30 Mar 2018 15:36:03 -0400
python-docker (2.5.1-1) unstable; urgency=medium
diff --git a/debian/control b/debian/control
index ee28069..a6fed11 100644
--- a/debian/control
+++ b/debian/control
@@ -13,19 +13,19 @@ Build-Depends: debhelper (>= 10),
python-requests (>= 2.11.1~),
python-six (>= 1.4.0~),
python-websocket (>= 0.32.0~),
- python-dockerpycreds (>= 0.2.1),
+ python-dockerpycreds (>= 0.2.2),
python-backports.ssl-match-hostname (>= 3.5),
python-ipaddress (>=1.0.16),
# setup.py - python3
python3-requests (>= 2.11.1~),
python3-six (>= 1.4.0~),
python3-websocket (>= 0.32.0~),
- python3-dockerpycreds (>= 0.2.1),
+ python3-dockerpycreds (>= 0.2.2),
# test-requirements.txt
# python-mock (>= 1.0.1~),
# python-coverage (>= 3.7.1~),
# docker.io,
-Standards-Version: 4.1.1
+Standards-Version: 4.1.3
Homepage: https://github.com/docker/docker-py
Vcs-Git: https://salsa.debian.org/docker-compose-team/python-docker
Vcs-Browser: https://salsa.debian.org/docker-compose-team/python-docker
@@ -39,7 +39,7 @@ Depends: ${misc:Depends}, ${python:Depends},
python-ipaddress (>=1.0.16)
Breaks: python-magnum (<< 5.0.0),
python-senlin (<< 2.0.0),
- docker-compose (<< 1.10)
+ docker-compose (<< 1.21)
Description: Python wrapper to access docker.io's control socket
This package contains oodles of routines that aid in controlling
docker.io over it's socket control, the same way the docker.io
diff --git a/debian/patches/requirements.patch b/debian/patches/requirements.patch
index 75180e3..a3aa38b 100644
--- a/debian/patches/requirements.patch
+++ b/debian/patches/requirements.patch
@@ -5,22 +5,16 @@ Subject: Unpin dependencies so newer versions satisfy them appropriately
Forwarded: https://github.com/dotcloud/docker-py/issues/101 (upstream has no interest)
Patch-Name: requirements.patch
----
- requirements.txt | 32 ++++++++++++++++----------------
- test-requirements.txt | 10 +++++-----
- 2 files changed, 21 insertions(+), 21 deletions(-)
-diff --git a/requirements.txt b/requirements.txt
-index f3c61e7..0e013c8 100644
--- a/requirements.txt
+++ b/requirements.txt
-@@ -1,16 +1,16 @@
+@@ -1,18 +1,18 @@
-appdirs==1.4.3
-asn1crypto==0.22.0
-backports.ssl-match-hostname==3.5.0.1
-cffi==1.10.0
-cryptography==1.9
--docker-pycreds==0.2.1
+-docker-pycreds==0.2.2
-enum34==1.1.6
-idna==2.5
-ipaddress==1.0.18
@@ -28,6 +22,8 @@ index f3c61e7..0e013c8 100644
-pycparser==2.17
-pyOpenSSL==17.0.0
-pyparsing==2.2.0
+-pypiwin32==219; sys_platform == 'win32' and python_version < '3.6'
+-pypiwin32==220; sys_platform == 'win32' and python_version >= '3.6'
-requests==2.14.2
-six==1.10.0
-websocket-client==0.40.0
@@ -36,7 +32,7 @@ index f3c61e7..0e013c8 100644
+backports.ssl-match-hostname>=3.5.0.1
+cffi>=1.10.0
+cryptography>=1.9
-+docker-pycreds>=0.2.1
++docker-pycreds>=0.2.2
+enum34>=1.1.6
+idna>=2.5
+ipaddress>=1.0.18
@@ -44,21 +40,23 @@ index f3c61e7..0e013c8 100644
+pycparser>=2.17
+pyOpenSSL>=17.0.0
+pyparsing>=2.2.0
++pypiwin32>=219; sys_platform == 'win32' and python_version < '3.6'
++pypiwin32>=220; sys_platform == 'win32' and python_version >= '3.6'
+requests>=2.14.2
+six>=1.10.0
+websocket-client>=0.40.0
-diff --git a/test-requirements.txt b/test-requirements.txt
-index 460db10..9f9eb50 100644
--- a/test-requirements.txt
+++ b/test-requirements.txt
-@@ -1,5 +1,5 @@
+@@ -1,6 +1,6 @@
+-coverage==3.7.1
+-flake8==3.4.1
-mock==1.0.1
-pytest==2.9.1
--coverage==3.7.1
-pytest-cov==2.1.0
--flake8==2.4.1
+-pytest-timeout==1.2.1
++coverage>=3.7.1
++flake8>=3.4.1
+mock>=1.0.1
+pytest>=2.9.1
-+coverage>=3.7.1
+pytest-cov>=2.1.0
-+flake8>=2.4.1
++pytest-timeout>=1.2.1