summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelipe Sateler <fsateler@debian.org>2017-11-05 10:38:34 -0300
committerFelipe Sateler <fsateler@debian.org>2017-11-05 10:38:34 -0300
commit23f18563a2bf39074d5f13fb210daccb105ee030 (patch)
tree09a001862dafe1a1cc9952ab59596aa2517bc4d5
parent936d30641ffeb16630707c032326170f617f43d9 (diff)
Refresh patches
-rw-r--r--debian/patches/Do-not-require-pip-for-building.patch2
-rw-r--r--debian/patches/requirements.patch46
2 files changed, 35 insertions, 13 deletions
diff --git a/debian/patches/Do-not-require-pip-for-building.patch b/debian/patches/Do-not-require-pip-for-building.patch
index 18d13d8..30bc1e5 100644
--- a/debian/patches/Do-not-require-pip-for-building.patch
+++ b/debian/patches/Do-not-require-pip-for-building.patch
@@ -9,7 +9,7 @@ but that doesn't matter in the context of a debian build
1 file changed, 9 deletions(-)
diff --git a/setup.py b/setup.py
-index 31180d2..0345fab 100644
+index 4a33c8d..e8f13ee 100644
--- a/setup.py
+++ b/setup.py
@@ -5,17 +5,8 @@ import codecs
diff --git a/debian/patches/requirements.patch b/debian/patches/requirements.patch
index 4c61bdd..75180e3 100644
--- a/debian/patches/requirements.patch
+++ b/debian/patches/requirements.patch
@@ -6,25 +6,47 @@ Forwarded: https://github.com/dotcloud/docker-py/issues/101 (upstream has no int
Patch-Name: requirements.patch
---
- requirements.txt | 8 ++++----
+ requirements.txt | 32 ++++++++++++++++----------------
test-requirements.txt | 10 +++++-----
- 2 files changed, 9 insertions(+), 9 deletions(-)
+ 2 files changed, 21 insertions(+), 21 deletions(-)
diff --git a/requirements.txt b/requirements.txt
-index 3754131..0ba845f 100644
+index f3c61e7..0e013c8 100644
--- a/requirements.txt
+++ b/requirements.txt
-@@ -1,6 +1,6 @@
--requests==2.11.1
-+requests>=2.11.1
- six>=1.4.0
--websocket-client==0.32.0
-+websocket-client>=0.32.0
- backports.ssl_match_hostname>=3.5 ; python_version < '3.5'
--ipaddress==1.0.16 ; python_version < '3.3'
+@@ -1,16 +1,16 @@
+-appdirs==1.4.3
+-asn1crypto==0.22.0
+-backports.ssl-match-hostname==3.5.0.1
+-cffi==1.10.0
+-cryptography==1.9
-docker-pycreds==0.2.1
-+ipaddress>=1.0.16 ; python_version < '3.3'
+-enum34==1.1.6
+-idna==2.5
+-ipaddress==1.0.18
+-packaging==16.8
+-pycparser==2.17
+-pyOpenSSL==17.0.0
+-pyparsing==2.2.0
+-requests==2.14.2
+-six==1.10.0
+-websocket-client==0.40.0
++appdirs>=1.4.3
++asn1crypto>=0.22.0
++backports.ssl-match-hostname>=3.5.0.1
++cffi>=1.10.0
++cryptography>=1.9
+docker-pycreds>=0.2.1
++enum34>=1.1.6
++idna>=2.5
++ipaddress>=1.0.18
++packaging>=16.8
++pycparser>=2.17
++pyOpenSSL>=17.0.0
++pyparsing>=2.2.0
++requests>=2.14.2
++six>=1.10.0
++websocket-client>=0.40.0
diff --git a/test-requirements.txt b/test-requirements.txt
index 460db10..9f9eb50 100644
--- a/test-requirements.txt