summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/Dockerfile18
-rw-r--r--debian/changelog245
-rw-r--r--debian/compat1
-rw-r--r--debian/control34
-rw-r--r--debian/copyright31
-rw-r--r--debian/gbp.conf8
-rw-r--r--debian/patches/requirements.patch62
-rw-r--r--debian/patches/series1
-rw-r--r--debian/pydist-overrides1
-rwxr-xr-xdebian/rules13
-rw-r--r--debian/source/format1
-rw-r--r--debian/tests/control3
-rwxr-xr-xdebian/tests/integration4
-rw-r--r--debian/watch3
14 files changed, 425 insertions, 0 deletions
diff --git a/debian/Dockerfile b/debian/Dockerfile
new file mode 100644
index 0000000..c26ccbc
--- /dev/null
+++ b/debian/Dockerfile
@@ -0,0 +1,18 @@
+FROM tianon/debian-devel
+
+# start by adding just "debian/control" so we can get mk-build-deps with maximum caching
+COPY control /usr/src/python-docker/debian/
+WORKDIR /usr/src/python-docker
+
+# get all the build deps of _this_ package in a nice repeatable way
+RUN apt-get update && mk-build-deps -irt'apt-get --no-install-recommends -yV' debian/control && dpkg-checkbuilddeps
+
+# need our debian/ directory to compile _this_ package
+COPY . /usr/src/python-docker/debian
+
+# go download and unpack our upstream source
+RUN uscan --force-download --verbose --download-current-version
+RUN origtargz --unpack
+
+# tianon is _really_ lazy, and likes a preseeded bash history
+RUN echo 'origtargz --unpack && dpkg-buildpackage -us -uc && lintian -EvIL+pedantic' >> "$HOME/.bash_history"
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..915b183
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,245 @@
+python-docker (3.4.1-4.1) unstable; urgency=medium
+
+ * Non-maintainer upload.
+ * Drop python2 support; Closes: #937714
+
+ -- Sandro Tosi <morph@debian.org> Sat, 19 Oct 2019 17:48:18 -0400
+
+python-docker (3.4.1-4) unstable; urgency=medium
+
+ * Revert "Drop dependency on ssl-match-hostname backport"
+ Turns out the python2 backport is not full enough as it does not
+ include the full functionality of py3.5 match_hostname.
+ Reopens: #909974
+ Closes: #918154
+
+ -- Felipe Sateler <fsateler@debian.org> Thu, 10 Jan 2019 19:35:42 -0300
+
+python-docker (3.4.1-3) unstable; urgency=medium
+
+ * Also drop the ssl-match-hostname Build-Depends
+
+ -- Felipe Sateler <fsateler@debian.org> Wed, 10 Oct 2018 10:05:22 -0300
+
+python-docker (3.4.1-2) unstable; urgency=medium
+
+ * Drop dependency on ssl-match-hostname backport.
+ The debian package for python has the backport built in. See #86989.
+ (Closes: #909972)
+ * Shorten changelog line
+ * Bump Standards-Version and drop X-Python-Version.
+ The latter is no longer needed
+ * Upload to unstable
+
+ -- Felipe Sateler <fsateler@debian.org> Tue, 02 Oct 2018 16:37:29 -0300
+
+python-docker (3.4.1-1) experimental; urgency=medium
+
+ [ Felipe Sateler ]
+ * Set team address as Maintainer
+ * Release to experimental
+
+ [ Alexander Gerasiov ]
+ * New upstream version 3.4.1
+ * d/patches refreshed.
+ requirements.patch updated to newer versions in upstream file.
+ Do-not-require-pip-for-building.patch removed (upstream removed this code
+ itself).
+
+ -- Felipe Sateler <fsateler@debian.org> Wed, 05 Sep 2018 20:08:46 -0300
+
+python-docker (3.2.1-1) experimental; urgency=medium
+
+ [ Jason Pleau ]
+ * New upstream release
+ * Update Vcs-* fields to point to salsa.d.o
+ * Refresh requirements.patch
+ * Update Standards-Version to 4.1.3, no changes needed
+ * Add Breaks for docker-compose << 1.21
+
+ [ Felipe Sateler ]
+ * Upload to experimental, to shake out possibly incompatible reverse
+ dependencies.
+
+ -- Felipe Sateler <fsateler@debian.org> Tue, 17 Apr 2018 19:57:43 -0300
+
+python-docker (2.5.1-1) unstable; urgency=medium
+
+ * New upstream version 2.5.1
+ - Refresh patches
+ * Pick dependencies from setup.py instead of requirements.txt.
+ Setup.py is the real thing, plus upstream added deps of deps to requirements.txt
+ * Use https for the watch file
+
+ -- Felipe Sateler <fsateler@debian.org> Sun, 05 Nov 2017 11:00:09 -0300
+
+python-docker (2.4.2-2) unstable; urgency=medium
+
+ [ Thomas Goirand ]
+ * Add Breaks: python-magnum (<< 5.0.0), python-senlin (<< 2.0.0).
+
+ [ Felipe Sateler ]
+ * Add Breaks for docker-compose << 1.10. (Closes: #870003)
+ * Bump Standards Version
+ * Release to unstable (Closes: #850741)
+
+ -- Felipe Sateler <fsateler@debian.org> Sat, 04 Nov 2017 10:58:35 -0300
+
+python-docker (2.4.2-1) experimental; urgency=medium
+
+ [ Jason Pleau ]
+ * New upstream release
+ * Refresh requirements patch
+ * Update dependencies for new upstream version
+ * Add myself to debian/copyright
+
+ [ Felipe Sateler ]
+ * Do not require pip for building.
+ It is only used to check for docker-py existece,
+ but that doesn't matter in the context of a debian build
+ * Bump standards-version to 4.0.0
+ * Sync dependency versions in python3 and python versions
+ * Bump debhelper compat to 10
+
+ -- Felipe Sateler <fsateler@debian.org> Sun, 16 Jul 2017 11:58:44 -0400
+
+python-docker (1.9.0-1) unstable; urgency=medium
+
+ [ Ondřej Nový ]
+ * New upstream release (Closes: #830172)
+ * Dropped
+ d/p/0002-Lower-Docker-API-version-to-1.20-for-Docker-1.8.3-co.patch
+ (Not needed anymore)
+ * Bump required version of python3-websocket to 0.32.0
+ * Standards-Version is 3.9.8 now (no change)
+ * Fixed typo in description
+
+ [ Andreas Henriksson ]
+ * autopkgtest: fix running of integration test
+
+ [ Felipe Sateler ]
+ * Take over the package from the DPMT. Thanks for all the work!
+ - Update Vcs urls
+ * Switch to git-buildpackage for vcs
+ * python2: add ssl_match_hostname and ipaddress dependencies
+ * Restrict python3 package to python 3.5
+
+ -- Felipe Sateler <fsateler@debian.org> Fri, 14 Oct 2016 21:15:59 -0300
+
+python-docker (1.7.2-1) unstable; urgency=medium
+
+ * Team upload.
+ * New upstream release (Closes: #816622).
+ * Standards-Version is 3.9.7 now (no change).
+ * Changed Vcs-Git URL to https.
+ * Added myself to d/copyright.
+ * Lower Docker API version to 1.20 for Docker 1.8.3 compatibility
+
+ -- Ondřej Nový <novy@ondrej.org> Wed, 23 Mar 2016 07:26:35 +0100
+
+python-docker (1.5.0-1) unstable; urgency=medium
+
+ * Update to 1.5.0 upstream release.
+
+ -- Tianon Gravi <tianon@debian.org> Sun, 08 Nov 2015 12:59:38 -0800
+
+python-docker (1.3.1-1) unstable; urgency=medium
+
+ * Update to 1.3.1 upstream release.
+
+ -- Tianon Gravi <admwiggin@gmail.com> Tue, 28 Jul 2015 13:25:20 -0700
+
+python-docker (1.3.0-2) unstable; urgency=medium
+
+ * Update 01_requirements.patch to reflect that the requirements are actually
+ stored in no less than three separate files (Closes: #793024).
+ * Add a DEP8 test that runs upstream's integration tests to verify
+ basic functionality.
+ * Patch the default API version down one notch to match src:docker.io (to be
+ removed when Docker 1.7+ gets into the archive).
+
+ -- Tianon Gravi <admwiggin@gmail.com> Mon, 20 Jul 2015 18:03:45 +0000
+
+python-docker (1.3.0-1) unstable; urgency=medium
+
+ * Update to 1.3.0 upstream release.
+
+ -- Tianon Gravi <admwiggin@gmail.com> Thu, 16 Jul 2015 18:00:39 +0000
+
+python-docker (1.2.3-1) unstable; urgency=medium
+
+ * Update to 1.2.3 upstream release (Closes: #790817).
+
+ -- Tianon Gravi <admwiggin@gmail.com> Thu, 02 Jul 2015 02:25:42 +0000
+
+python-docker (1.2.2-2) unstable; urgency=medium
+
+ * Relax requests dependency slightly to account for the accidental misupload
+ to unstable.
+
+ -- Tianon Gravi <admwiggin@gmail.com> Sun, 29 Mar 2015 19:58:18 -0600
+
+python-docker (1.2.2-1) unstable; urgency=medium
+
+ * Update to 1.2.2 upstream release (Closes: #781355)
+ * Update debian/watch to use the pypi.debian.net redirector
+ * Update Build-Depends, 01_requirements.patch, and comment in debian/rules
+ regarding tests
+
+ -- Tianon Gravi <admwiggin@gmail.com> Sun, 29 Mar 2015 19:58:18 -0600
+
+python-docker (0.5.3-2) unstable; urgency=medium
+
+ * Remove 02_use-system-urllib3.patch thanks to the fix in requests
+
+ -- Tianon Gravi <admwiggin@gmail.com> Thu, 13 Nov 2014 06:29:26 +0000
+
+python-docker (0.5.3-1.1) unstable; urgency=medium
+
+ * Non-maintainer upload.
+ * Added debian/patches/02_use-system-urllib3.patch (Closes: #767445).
+ * Renamed debian/patches/requirements.patch to
+ debian/patches/01_requirements.patch following convention from other
+ Python packages.
+
+ -- Jakub Warmuz <jakub@warmuz.org> Sat, 01 Nov 2014 18:19:57 +0100
+
+python-docker (0.5.3-1) unstable; urgency=medium
+
+ * Update to 0.5.3 upstream release
+ - 0.5.3: Fixed attaching when connecting to the daemon over a UNIX socket.
+ - 0.5.2: Fixed a bug where sockets were closed immediately when attaching
+ over TLS.
+
+ -- Tianon Gravi <admwiggin@gmail.com> Fri, 17 Oct 2014 06:12:19 +0000
+
+python-docker (0.5.1-1) unstable; urgency=medium
+
+ * Update to 0.5.1 upstream release
+
+ -- Tianon Gravi <admwiggin@gmail.com> Thu, 16 Oct 2014 07:05:26 +0000
+
+python-docker (0.5.0-1) unstable; urgency=medium
+
+ * Update to 0.5.0 upstream release
+
+ -- Tianon Gravi <admwiggin@gmail.com> Sun, 14 Sep 2014 00:56:13 +0000
+
+python-docker (0.4.0-1) unstable; urgency=medium
+
+ * Update to 0.4.0 upstream release
+
+ -- Tianon Gravi <admwiggin@gmail.com> Mon, 28 Jul 2014 10:43:40 -0600
+
+python-docker (0.3.2-1) unstable; urgency=medium
+
+ * Update to 0.3.2 upstream release
+ * Bump Standards-Version to 3.9.5
+
+ -- Tianon Gravi <admwiggin@gmail.com> Thu, 17 Jul 2014 21:51:51 -0400
+
+python-docker (0.2.3-1) unstable; urgency=low
+
+ * Initial release (Closes: #734679)
+
+ -- Paul Tagliamonte <paultag@debian.org> Mon, 10 Feb 2014 22:13:24 -0500
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..f599e28
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+10
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..28613a6
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,34 @@
+Source: python-docker
+Section: python
+Priority: optional
+Maintainer: Docker Compose Team <team+docker-compose@tracker.debian.org>
+Uploaders: Jason Pleau <jason@jpleau.ca>,
+ Felipe Sateler <fsateler@debian.org>
+Build-Depends: debhelper (>= 10),
+ dh-python,
+ python3-all,
+ python3-setuptools,
+# setup.py - python3
+ python3-requests (>= 2.11.1~),
+ python3-six (>= 1.4.0~),
+ python3-websocket (>= 0.32.0~),
+ python3-dockerpycreds (>= 0.2.2),
+# test-requirements.txt
+# python-mock (>= 1.0.1~),
+# python-coverage (>= 3.7.1~),
+# docker.io,
+Standards-Version: 4.2.1
+Homepage: https://github.com/docker/docker-py
+Vcs-Git: https://salsa.debian.org/docker-compose-team/python-docker
+Vcs-Browser: https://salsa.debian.org/docker-compose-team/python-docker
+X-Python3-Version: >= 3.5
+
+Package: python3-docker
+Architecture: all
+Depends: ${misc:Depends}, ${python3:Depends}
+Description: Python 3 wrapper to access docker.io's control socket
+ This package contains oodles of routines that aid in controlling
+ docker.io over it's socket control, the same way the docker.io
+ client controls the daemon.
+ .
+ This package provides Python 3 module bindings only.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..75d9002
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,31 @@
+Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0
+Upstream-Name: docker
+Upstream-Contact: Docker, Inc.
+Source: https://github.com/docker/docker-py
+
+Files: *
+Copyright: 2014 Docker, Inc.
+License: Apache-2.0
+
+Files: debian/*
+Copyright: 2014 Paul R. Tagliamonte <paultag@debian.org>
+ 2014 Tianon Gravi <tianon@debian.org>
+ 2016 Ondřej Nový <novy@ondrej.org>
+ 2017 Jason Pleau <jason@jpleau.ca>
+License: Apache-2.0
+
+License: Apache-2.0
+ Licensed under the Apache License, Version 2.0 (the "License");
+ you may not use this file except in compliance with the License.
+ You may obtain a copy of the License at
+ .
+ http://www.apache.org/licenses/LICENSE-2.0
+ .
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
+ .
+ On Debian systems, the complete text of the Apache version 2.0 license
+ can be found in "/usr/share/common-licenses/Apache-2.0".
diff --git a/debian/gbp.conf b/debian/gbp.conf
new file mode 100644
index 0000000..6dc3643
--- /dev/null
+++ b/debian/gbp.conf
@@ -0,0 +1,8 @@
+[DEFAULT]
+pristine-tar = True
+patch-numbers = False
+debian-branch = master
+
+[dch]
+full = True
+multimaint-merge = True
diff --git a/debian/patches/requirements.patch b/debian/patches/requirements.patch
new file mode 100644
index 0000000..e20baa4
--- /dev/null
+++ b/debian/patches/requirements.patch
@@ -0,0 +1,62 @@
+From: Tianon Gravi <tianon@debian.org>
+Date: Sun, 8 Nov 2015 10:36:49 -0800
+Subject: Unpin dependencies so newer versions satisfy them appropriately
+
+Forwarded: https://github.com/dotcloud/docker-py/issues/101 (upstream has no interest)
+
+Patch-Name: requirements.patch
+
+--- a/requirements.txt
++++ b/requirements.txt
+@@ -1,18 +1,18 @@
+-appdirs==1.4.3
+-asn1crypto==0.22.0
+-backports.ssl-match-hostname==3.5.0.1
+-cffi==1.10.0
+-cryptography==1.9
+-docker-pycreds==0.3.0
+-enum34==1.1.6
+-idna==2.5
+-ipaddress==1.0.18
+-packaging==16.8
+-pycparser==2.17
+-pyOpenSSL==17.0.0
+-pyparsing==2.2.0
+-pypiwin32==219; sys_platform == 'win32' and python_version < '3.6'
+-pypiwin32==220; sys_platform == 'win32' and python_version >= '3.6'
+-requests==2.14.2
+-six==1.10.0
+-websocket-client==0.40.0
++appdirs>=1.4.3
++asn1crypto>=0.22.0
++backports.ssl-match-hostname>=3.5.0.1
++cffi>=1.10.0
++cryptography>=1.9
++docker-pycreds>=0.3.0
++enum34>=1.1.6
++idna>=2.5
++ipaddress>=1.0.18
++packaging>=16.8
++pycparser>=2.17
++pyOpenSSL>=17.0.0
++pyparsing>=2.2.0
++pypiwin32>=219; sys_platform == 'win32' and python_version < '3.6'
++pypiwin32>=220; sys_platform == 'win32' and python_version >= '3.6'
++requests>=2.14.2
++six>=1.10.0
++websocket-client>=0.40.0
+--- a/test-requirements.txt
++++ b/test-requirements.txt
+@@ -1,6 +1,6 @@
+-coverage==3.7.1
+-flake8==3.4.1
+-mock==1.0.1
+-pytest==2.9.1
+-pytest-cov==2.1.0
+-pytest-timeout==1.2.1
++coverage>=3.7.1
++flake8>=3.4.1
++mock>=1.0.1
++pytest>=2.9.1
++pytest-cov>=2.1.0
++pytest-timeout>=1.2.1
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..f499a22
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+requirements.patch
diff --git a/debian/pydist-overrides b/debian/pydist-overrides
new file mode 100644
index 0000000..e5dee6e
--- /dev/null
+++ b/debian/pydist-overrides
@@ -0,0 +1 @@
+websocket-client python-websocket
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..9ffd4ee
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,13 @@
+#!/usr/bin/make -f
+
+export PYBUILD_NAME=docker
+
+# The pypi bundle includes the tests (https://github.com/docker/docker-py/issues/308), but they're really invasive and fail for reasons I haven't yet diagnosed.
+export PYBUILD_DISABLE=test
+
+override_dh_auto_clean:
+ dh_auto_clean
+ rm -f docker_py.egg-info/SOURCES.txt
+
+%:
+ dh $@ --with python3 --buildsystem pybuild
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/tests/control b/debian/tests/control
new file mode 100644
index 0000000..6163e1b
--- /dev/null
+++ b/debian/tests/control
@@ -0,0 +1,3 @@
+Tests: integration
+Depends: docker.io, python3-mock, python3-pytest, @
+Restrictions: isolation-machine needs-root
diff --git a/debian/tests/integration b/debian/tests/integration
new file mode 100755
index 0000000..2012a95
--- /dev/null
+++ b/debian/tests/integration
@@ -0,0 +1,4 @@
+#!/bin/bash
+set -e
+
+py.test-3 tests/integration/
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 0000000..99f8c16
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,3 @@
+version=3
+opts=uversionmangle=s/-?(rc|a|b|c)/~$1/ \
+https://pypi.debian.net/docker/docker-(.+)\.(?:zip|tgz|tbz|txz|(?:tar\.(?:gz|bz2|xz)))