summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog10
-rw-r--r--debian/control2
-rw-r--r--debian/patches/Drop-dependency-on-ssl-match-hostname-backport.patch24
-rw-r--r--debian/patches/series1
-rw-r--r--setup.py1
5 files changed, 13 insertions, 25 deletions
diff --git a/debian/changelog b/debian/changelog
index d52a957..6686d66 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+python-docker (3.4.1-4) unstable; urgency=medium
+
+ * Revert "Drop dependency on ssl-match-hostname backport"
+ Turns out the python2 backport is not full enough as it does not
+ include the full functionality of py3.5 match_hostname.
+ Reopens: #909974
+ Closes: #918154
+
+ -- Felipe Sateler <fsateler@debian.org> Thu, 10 Jan 2019 19:35:42 -0300
+
python-docker (3.4.1-3) unstable; urgency=medium
* Also drop the ssl-match-hostname Build-Depends
diff --git a/debian/control b/debian/control
index fe5ea62..54d92ba 100644
--- a/debian/control
+++ b/debian/control
@@ -15,6 +15,7 @@ Build-Depends: debhelper (>= 10),
python-six (>= 1.4.0~),
python-websocket (>= 0.32.0~),
python-dockerpycreds (>= 0.2.2),
+ python-backports.ssl-match-hostname (>= 3.5),
python-ipaddress (>=1.0.16),
# setup.py - python3
python3-requests (>= 2.11.1~),
@@ -34,6 +35,7 @@ X-Python3-Version: >= 3.5
Package: python-docker
Architecture: all
Depends: ${misc:Depends}, ${python:Depends},
+ python-backports.ssl-match-hostname (>= 3.5),
python-ipaddress (>=1.0.16)
Breaks: python-magnum (<< 5.0.0),
python-senlin (<< 2.0.0),
diff --git a/debian/patches/Drop-dependency-on-ssl-match-hostname-backport.patch b/debian/patches/Drop-dependency-on-ssl-match-hostname-backport.patch
deleted file mode 100644
index d8c8472..0000000
--- a/debian/patches/Drop-dependency-on-ssl-match-hostname-backport.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From: Felipe Sateler <fsateler@debian.org>
-Date: Tue, 2 Oct 2018 16:33:29 -0300
-Subject: Drop dependency on ssl-match-hostname backport
-
-The debian package for python has the backport built in. See #86989.
-
-Closes: #909972
-Forwarded: not-needed
----
- setup.py | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/setup.py b/setup.py
-index 57b2b5a..553e7b2 100644
---- a/setup.py
-+++ b/setup.py
-@@ -17,7 +17,6 @@ requirements = [
- ]
-
- extras_require = {
-- ':python_version < "3.5"': 'backports.ssl_match_hostname >= 3.5',
- # While not imported explicitly, the ipaddress module is required for
- # ssl_match_hostname to verify hosts match with certificates via
- # ServerAltname: https://pypi.python.org/pypi/backports.ssl_match_hostname
diff --git a/debian/patches/series b/debian/patches/series
index 670547a..f499a22 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1 @@
requirements.patch
-Drop-dependency-on-ssl-match-hostname-backport.patch
diff --git a/setup.py b/setup.py
index 553e7b2..57b2b5a 100644
--- a/setup.py
+++ b/setup.py
@@ -17,6 +17,7 @@ requirements = [
]
extras_require = {
+ ':python_version < "3.5"': 'backports.ssl_match_hostname >= 3.5',
# While not imported explicitly, the ipaddress module is required for
# ssl_match_hostname to verify hosts match with certificates via
# ServerAltname: https://pypi.python.org/pypi/backports.ssl_match_hostname