summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron M. Ucko <ucko@debian.org>2011-10-22 23:57:55 +0000
committerAaron M. Ucko <ucko@debian.org>2011-10-22 23:57:55 +0000
commit06874d97e494cd57177c09fc7a96d25abb756adb (patch)
treedb8b11ba4b9fd63acbf547953f18bd5b8a05657b
parent61b1ee8c15629f66a10e37ad6df08d2249894f11 (diff)
* debian/rules: invoke dh --with python2.
* debian/control: - Tighten build-dependency on python to (>= 2.6.6-3~) for dh_python2. - Drop build-dependency on python-support, now superfluous. - Formally set Provides: ${python:Provides}. * debian/pycompat: belatedly retire as obsolete.
-rw-r--r--debian/changelog8
-rw-r--r--debian/control3
-rw-r--r--debian/pycompat1
-rwxr-xr-xdebian/rules2
4 files changed, 9 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index b06df6e..db9435e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,10 +4,14 @@ python-dsv (1.4.1-2) UNRELEASED; urgency=low
* debian/source/format: advance to 3.0 (quilt).
* debian/rules:
- Simplify accordingly; now fully minimal.
+ - Invoke dh --with python2.
* debian/control:
- - Drop build-dependency on quilt, now superfluous.
+ - Tighten build dependency on python to (>= 2.6.6-3~) for dh_python2.
+ - Drop build dependencies on python-support and quilt, now superfluous.
+ - Formally set Provides: ${python:Provides}.
+ * debian/pycompat: belatedly retire as obsolete.
- -- Aaron M. Ucko <ucko@debian.org> Sat, 22 Oct 2011 19:43:37 -0400
+ -- Aaron M. Ucko <ucko@debian.org> Sat, 22 Oct 2011 19:57:51 -0400
python-dsv (1.4.1-1) unstable; urgency=low
diff --git a/debian/control b/debian/control
index 2259032..673583d 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: python
Priority: optional
Maintainer: Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
Uploaders: Aaron M. Ucko <ucko@debian.org>
-Build-Depends: debhelper (>= 7.0.8), python (>= 2.3.5-7), python-support (>= 0.5.3)
+Build-Depends: debhelper (>= 7.0.8), python (>= 2.6.6-3~)
Standards-Version: 3.8.3
Vcs-Svn: svn://svn.debian.org/python-modules/packages/python-dsv/trunk
Vcs-Browser: http://svn.debian.org/viewsvn/python-modules/packages/python-dsv/trunk/
@@ -13,6 +13,7 @@ Package: python-dsv
Architecture: all
Depends: ${misc:Depends}, ${python:Depends}
Suggests: python-wxgtk2.8 | python-wxgtk2.6
+Provides: ${python:Provides}
Description: Python module for delimiter-separated-value files
Python-DSV is an alternative to Python's standard csv module, with
somewhat different usage and optional support for wxWidgets-mediated
diff --git a/debian/pycompat b/debian/pycompat
deleted file mode 100644
index 0cfbf08..0000000
--- a/debian/pycompat
+++ /dev/null
@@ -1 +0,0 @@
-2
diff --git a/debian/rules b/debian/rules
index cbe925d..18bcae9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,3 +1,3 @@
#!/usr/bin/make -f
%:
- dh $@
+ dh $@ --with python2