summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChristoph Egger <christoph@debian.org>2017-05-28 14:30:29 +0200
committerChristoph Egger <christoph@debian.org>2017-05-28 14:30:29 +0200
commitfc98900adb70b6316f991fe16726dc24b568cb52 (patch)
treeaf00c153db0f97c5280369fdb5f23d4636f673dc /setup.py
parentc83668fff106e313beb66b8c09bdce1e9844fd3c (diff)
parent9f30a9497bb1e812acfdf1c98e3b5cf35ddd8e39 (diff)
Updated version 0.0~vcs.2017.05.26.git from '0.0_vcs.2017.05.26.git'
with Debian dir e44e7e9b159453b5fa19fb0c2508a7173ffe82a3
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py18
1 files changed, 9 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 19ae57c..95d55e8 100644
--- a/setup.py
+++ b/setup.py
@@ -7,22 +7,22 @@ import sys
source_files = ["enet.pyx"]
-# _enet_files = glob.glob("enet/*.c")
+_enet_files = glob.glob("enet/*.c")
-# if not _enet_files:
-# print("You need to download and extract the enet 1.3 source to enet/")
-# print("Download the source from: http://enet.bespin.org/SourceDistro.html")
-# print("See the README for more instructions")
-# sys.exit(1)
-#
-# source_files.extend(_enet_files)
+if not _enet_files:
+ print("You need to download and extract the enet 1.3 source to enet/")
+ print("Download the source from: http://enet.bespin.org/SourceDistro.html")
+ print("See the README for more instructions")
+ sys.exit(1)
+
+source_files.extend(_enet_files)
define_macros = [('HAS_POLL', None),
('HAS_FCNTL', None),
('HAS_MSGHDR_FLAGS', None),
('HAS_SOCKLEN_T', None) ]
-libraries = ['enet']
+libraries = []
if sys.platform == 'win32':
define_macros.extend([('WIN32', None)])