summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/patches/build-against-system-enet.patch39
-rw-r--r--debian/patches/debian-changes61
-rw-r--r--debian/patches/series2
3 files changed, 62 insertions, 40 deletions
diff --git a/debian/patches/build-against-system-enet.patch b/debian/patches/build-against-system-enet.patch
deleted file mode 100644
index c02d7f5..0000000
--- a/debian/patches/build-against-system-enet.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-Description: Make python-enet build against system libenet 0.0~svn21-1
-Origin: debian
-Forwarded: no
-Last-Update: 2011-05-01
-
---- python-enet-0.0~svn21.orig/setup.py
-+++ python-enet-0.0~svn21/setup.py
-@@ -31,22 +31,22 @@ import sys
-
- source_files = ["enet.pyx"]
-
--_enet_files = glob.glob("enet/*.c")
-+# _enet_files = glob.glob("enet/*.c")
-
--if not _enet_files:
-- print("You need to download and extract the enet 1.3 source to enet/")
-- print("Download the source from: http://enet.bespin.org/SourceDistro.html")
-- print("See the README for more instructions")
-- sys.exit(1)
--
--source_files.extend(_enet_files)
-+# if not _enet_files:
-+# print("You need to download and extract the enet 1.3 source to enet/")
-+# print("Download the source from: http://enet.bespin.org/SourceDistro.html")
-+# print("See the README for more instructions")
-+# sys.exit(1)
-+#
-+# source_files.extend(_enet_files)
-
- define_macros = [('HAS_POLL', None),
- ('HAS_FCNTL', None),
- ('HAS_MSGHDR_FLAGS', None),
- ('HAS_SOCKLEN_T', None) ]
-
--libraries = []
-+libraries = ['enet']
-
- if sys.platform == 'win32':
- define_macros.extend([('WIN32', None)])
diff --git a/debian/patches/debian-changes b/debian/patches/debian-changes
new file mode 100644
index 0000000..a2c53a8
--- /dev/null
+++ b/debian/patches/debian-changes
@@ -0,0 +1,61 @@
+Description: <short summary of the patch>
+ TODO: Put a short summary on the line above and replace this paragraph
+ with a longer explanation of this change. Complete the meta-information
+ with other relevant fields (see below for details). To make it easier, the
+ information below has been extracted from the changelog. Adjust it or drop
+ it.
+ .
+ python-enet (0.0~vcs.2017.05.26.git-1) UNRELEASED; urgency=medium
+ .
+ * New upstream snapshot
+ * Enable python3
+ * Use dgit for package
+Author: Christoph Egger <christoph@debian.org>
+
+---
+The information above should follow the Patch Tagging Guidelines, please
+checkout http://dep.debian.net/deps/dep3/ to learn about the format. Here
+are templates for supplementary fields that you might want to add:
+
+Origin: <vendor|upstream|other>, <url of original patch>
+Bug: <url in upstream bugtracker>
+Bug-Debian: https://bugs.debian.org/<bugnumber>
+Bug-Ubuntu: https://launchpad.net/bugs/<bugnumber>
+Forwarded: <no|not-needed|url proving that it has been forwarded>
+Reviewed-By: <name and email of someone who approved the patch>
+Last-Update: 2017-05-28
+
+--- python-enet-0.0~vcs.2017.05.26.git.orig/setup.py
++++ python-enet-0.0~vcs.2017.05.26.git/setup.py
+@@ -7,22 +7,22 @@ import sys
+
+ source_files = ["enet.pyx"]
+
+-_enet_files = glob.glob("enet/*.c")
++# _enet_files = glob.glob("enet/*.c")
+
+-if not _enet_files:
+- print("You need to download and extract the enet 1.3 source to enet/")
+- print("Download the source from: http://enet.bespin.org/SourceDistro.html")
+- print("See the README for more instructions")
+- sys.exit(1)
+-
+-source_files.extend(_enet_files)
++# if not _enet_files:
++# print("You need to download and extract the enet 1.3 source to enet/")
++# print("Download the source from: http://enet.bespin.org/SourceDistro.html")
++# print("See the README for more instructions")
++# sys.exit(1)
++#
++# source_files.extend(_enet_files)
+
+ define_macros = [('HAS_POLL', None),
+ ('HAS_FCNTL', None),
+ ('HAS_MSGHDR_FLAGS', None),
+ ('HAS_SOCKLEN_T', None) ]
+
+-libraries = []
++libraries = ['enet']
+
+ if sys.platform == 'win32':
+ define_macros.extend([('WIN32', None)])
diff --git a/debian/patches/series b/debian/patches/series
index deb9b7b..7bb8252 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1 @@
-build-against-system-enet.patch
+debian-changes