summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/compat2
-rw-r--r--debian/control35
-rw-r--r--debian/docs2
-rw-r--r--debian/python-enet.install1
-rw-r--r--debian/python3-enet.install1
-rwxr-xr-xdebian/rules7
6 files changed, 32 insertions, 16 deletions
diff --git a/debian/compat b/debian/compat
index 7f8f011..f599e28 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-7
+10
diff --git a/debian/control b/debian/control
index 5cd3057..80be44a 100644
--- a/debian/control
+++ b/debian/control
@@ -2,22 +2,41 @@ Source: python-enet
Section: python
Priority: optional
Maintainer: Christoph Egger <christoph@debian.org>
-Build-Depends: debhelper (>= 7.0.50~),
- python-all-dev,
+Build-Depends:
cython,
- libenet-dev
-Standards-Version: 3.9.2
+ cython3,
+ debhelper (>= 10~),
+ dh-python,
+ libenet-dev,
+ python-dev,
+ python3-dev
+Standards-Version: 3.9.8
Homepage: https://github.com/aresch/pyenet
Vcs-Browser: https://browse.dgit.debian.org/python-enet.git/
Vcs-Git: https://git.dgit.debian.org/python-enet
Package: python-enet
Architecture: any
-Depends: ${shlibs:Depends},
+Depends:
${misc:Depends},
- ${python:Depends}
-Breaks: ${python:Breaks}
-Description: wrapper for the ENet library
+ ${python:Depends},
+ ${shlibs:Depends}
+Breaks:
+ ${python:Breaks}
+Description: Python2 wrapper for the ENet library
+ python-enet provides a thin wrapper around the enet networking
+ library. ENet is a thin layer to provide reliable comunication over
+ UDP.
+
+Package: python3-enet
+Architecture: any
+Depends:
+ ${misc:Depends},
+ ${python:Depends},
+ ${shlibs:Depends}
+Breaks:
+ ${python:Breaks}
+Description: Python3 wrapper for the ENet library
python-enet provides a thin wrapper around the enet networking
library. ENet is a thin layer to provide reliable comunication over
UDP.
diff --git a/debian/docs b/debian/docs
index e845566..b43bf86 100644
--- a/debian/docs
+++ b/debian/docs
@@ -1 +1 @@
-README
+README.md
diff --git a/debian/python-enet.install b/debian/python-enet.install
new file mode 100644
index 0000000..d0a67d5
--- /dev/null
+++ b/debian/python-enet.install
@@ -0,0 +1 @@
+usr/lib/python2*/dist-packages/
diff --git a/debian/python3-enet.install b/debian/python3-enet.install
new file mode 100644
index 0000000..c1ecddb
--- /dev/null
+++ b/debian/python3-enet.install
@@ -0,0 +1 @@
+usr/lib/python3*/dist-packages/
diff --git a/debian/rules b/debian/rules
index a543ea9..394bcba 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,13 +1,8 @@
#!/usr/bin/make -f
# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
%:
- dh --with python2 $@
+ dh $@ --buildsystem=pybuild --with python2,python3