summaryrefslogtreecommitdiff
path: root/patches
diff options
context:
space:
mode:
Diffstat (limited to 'patches')
-rw-r--r--patches/build-against-system-enet.patch39
-rw-r--r--patches/series1
2 files changed, 40 insertions, 0 deletions
diff --git a/patches/build-against-system-enet.patch b/patches/build-against-system-enet.patch
new file mode 100644
index 0000000..c02d7f5
--- /dev/null
+++ b/patches/build-against-system-enet.patch
@@ -0,0 +1,39 @@
+Description: Make python-enet build against system libenet 0.0~svn21-1
+Origin: debian
+Forwarded: no
+Last-Update: 2011-05-01
+
+--- python-enet-0.0~svn21.orig/setup.py
++++ python-enet-0.0~svn21/setup.py
+@@ -31,22 +31,22 @@ import sys
+
+ source_files = ["enet.pyx"]
+
+-_enet_files = glob.glob("enet/*.c")
++# _enet_files = glob.glob("enet/*.c")
+
+-if not _enet_files:
+- print("You need to download and extract the enet 1.3 source to enet/")
+- print("Download the source from: http://enet.bespin.org/SourceDistro.html")
+- print("See the README for more instructions")
+- sys.exit(1)
+-
+-source_files.extend(_enet_files)
++# if not _enet_files:
++# print("You need to download and extract the enet 1.3 source to enet/")
++# print("Download the source from: http://enet.bespin.org/SourceDistro.html")
++# print("See the README for more instructions")
++# sys.exit(1)
++#
++# source_files.extend(_enet_files)
+
+ define_macros = [('HAS_POLL', None),
+ ('HAS_FCNTL', None),
+ ('HAS_MSGHDR_FLAGS', None),
+ ('HAS_SOCKLEN_T', None) ]
+
+-libraries = []
++libraries = ['enet']
+
+ if sys.platform == 'win32':
+ define_macros.extend([('WIN32', None)])
diff --git a/patches/series b/patches/series
new file mode 100644
index 0000000..deb9b7b
--- /dev/null
+++ b/patches/series
@@ -0,0 +1 @@
+build-against-system-enet.patch