summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py18
1 files changed, 9 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 95d55e8..19ae57c 100644
--- a/setup.py
+++ b/setup.py
@@ -7,22 +7,22 @@ import sys
source_files = ["enet.pyx"]
-_enet_files = glob.glob("enet/*.c")
+# _enet_files = glob.glob("enet/*.c")
-if not _enet_files:
- print("You need to download and extract the enet 1.3 source to enet/")
- print("Download the source from: http://enet.bespin.org/SourceDistro.html")
- print("See the README for more instructions")
- sys.exit(1)
-
-source_files.extend(_enet_files)
+# if not _enet_files:
+# print("You need to download and extract the enet 1.3 source to enet/")
+# print("Download the source from: http://enet.bespin.org/SourceDistro.html")
+# print("See the README for more instructions")
+# sys.exit(1)
+#
+# source_files.extend(_enet_files)
define_macros = [('HAS_POLL', None),
('HAS_FCNTL', None),
('HAS_MSGHDR_FLAGS', None),
('HAS_SOCKLEN_T', None) ]
-libraries = []
+libraries = ['enet']
if sys.platform == 'win32':
define_macros.extend([('WIN32', None)])