summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@jelmer.uk>2015-10-25 22:34:02 +0000
committerJelmer Vernooij <jelmer@jelmer.uk>2015-10-25 22:34:02 +0000
commit555a104687ff7bcf6d319c1f46ea89474df12fee (patch)
treef03e8324d6cab70db3884af9b4a1f64bbca9872c
parentffe0bfbb0e1a198a2dbee434faf46494211382d4 (diff)
Install to actual packages.
-rwxr-xr-xdebian/rules4
1 files changed, 3 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 62b8702..9e2be5b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,4 +8,6 @@ override_dh_auto_install:
set -ex; for python in $(shell py3versions -r); do \
$$python setup.py install --root=$(CURDIR)/debian/tmp --install-layout=deb; \
done;
-
+ # Install everything excluding the *_d.so debug extensions to python-etcd and python3-etcd
+ dh_install -X"*_d.so" "debian/tmp/usr/lib/python2*/*-packages" -p python-etcd
+ dh_install -X"*_d.so" "debian/tmp/usr/lib/python3*/*-packages" -p python3-etcd