summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@jelmer.uk>2015-10-25 22:32:39 +0000
committerJelmer Vernooij <jelmer@jelmer.uk>2015-10-25 22:32:39 +0000
commitffe0bfbb0e1a198a2dbee434faf46494211382d4 (patch)
tree7c59af68d85b84629109afd37ba456c8279e9091
parent25a67f46c21ec26076b5bd83c97ad4a7451b602d (diff)
Install python3.
-rwxr-xr-xdebian/rules9
1 files changed, 8 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 24e6a61..62b8702 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,4 +1,11 @@
#!/usr/bin/make -f
%:
- dh $* --with python2,python3 --buildsystem=python_distutils
+ dh $* --with python2,python3
+
+override_dh_auto_install:
+ dh_auto_install
+ set -ex; for python in $(shell py3versions -r); do \
+ $$python setup.py install --root=$(CURDIR)/debian/tmp --install-layout=deb; \
+ done;
+