summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiuseppe Lavagetto <lavagetto@gmail.com>2015-12-02 18:18:24 +0100
committerGiuseppe Lavagetto <lavagetto@gmail.com>2015-12-02 18:40:25 +0100
commit0129a43e1abe66b2844e97443e8c1ee9f36527a6 (patch)
treeb42a271fe1bfed365c2ac17476f2ca39962da131
parent469f29f4bfc39cbb31c786311500e3c81717cc16 (diff)
Release 0.4.3
Enough changes were important enough to grant a release, namely python 3.5 compatibility and authentication/ACLs. Also a ton of fixes that people would probably love to have. Added an AUTHORS file to acknowledge openly the work of all the contributors to the project.
-rw-r--r--AUTHORS37
-rw-r--r--NEWS.txt14
-rw-r--r--docs-source/conf.py4
-rw-r--r--setup.py2
4 files changed, 53 insertions, 4 deletions
diff --git a/AUTHORS b/AUTHORS
new file mode 100644
index 0000000..0f07ed1
--- /dev/null
+++ b/AUTHORS
@@ -0,0 +1,37 @@
+Maintainers:
+-----------
+Jose Plana (jplana)
+Giuseppe Lavagetto (lavagetto)
+
+Contributors:
+------------
+Aleksandar Veselinovic
+Alex Chan
+Alex Ianchici
+Bartlomiej Biernacki
+Bradley Cicenas
+Christoph Heer
+Hogenmiller
+Jimmy Zelinskie
+Jim Rollenhagen
+John Kristensen
+Joshua Conner
+Matthias Urlichs
+Michal Witkowski
+Nick Bartos
+Peter Wagner
+Roberto Aguilar
+Roy Smith
+Ryan Fowler
+Samuel Marks
+Sergio Castaño Arteaga
+Shaun Crampton
+Sigmund Augdal
+Simeon Visser
+Simon Gomizelj
+SkyLothar
+Spike Curtis
+Tomas Kral
+Tom Denham
+WillPlatnick
+WooParadog
diff --git a/NEWS.txt b/NEWS.txt
index 2158c21..00b6a71 100644
--- a/NEWS.txt
+++ b/NEWS.txt
@@ -1,9 +1,21 @@
News
====
+0.4.3
+-----
+*Release date: 3-Dec-2015*
+
+* Python 3.5 compatibility and general python3 cleanups
+* Added authentication and module for managing ACLs
+* Added srv record-based DNS discovery
+* Fixed (again) logging of cluster id changes
+* Fixed leader lookup
+* Properly retry request on exception
+* Client: clean up open connections when deleting
+
0.4.2
-----
-*Release data: 8-Oct-2015*
+*Release date: 8-Oct-2015*
* Fixed lock documentation
* Fixed lock sequences due to etcd 2.2 change
diff --git a/docs-source/conf.py b/docs-source/conf.py
index 996cb61..5148c23 100644
--- a/docs-source/conf.py
+++ b/docs-source/conf.py
@@ -52,7 +52,7 @@ master_doc = 'index'
# General information about the project.
project = u'python-etcd'
-copyright = u'2013, Jose Plana'
+copyright = u'2013-2015 Jose Plana, Giuseppe Lavagetto'
# The version info for the project you're documenting, acts as replacement for
# |version| and |release|, also used in various other places throughout the
@@ -61,7 +61,7 @@ copyright = u'2013, Jose Plana'
# The short X.Y version.
version = '0.4'
# The full version, including alpha/beta/rc tags.
-release = '0.4.2'
+release = '0.4.3'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/setup.py b/setup.py
index 3d0d450..5387ef4 100644
--- a/setup.py
+++ b/setup.py
@@ -6,7 +6,7 @@ README = open(os.path.join(here, 'README.rst')).read()
NEWS = open(os.path.join(here, 'NEWS.txt')).read()
-version = '0.4.2'
+version = '0.4.3'
# Dnspython is two different packages depending on python version
if sys.version_info.major == 2: